summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 17:31:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-28 09:59:58 +0200
commit8b1e7fd32b497092bbe578e3bedd0e5fe0bcca8d (patch)
tree104b07225a982f024f7b3df27bac6eb817075426 /dev-python/twine
parentdev-python/pip: Port to py39 (diff)
downloadgentoo-8b1e7fd32b497092bbe578e3bedd0e5fe0bcca8d.tar.gz
gentoo-8b1e7fd32b497092bbe578e3bedd0e5fe0bcca8d.tar.bz2
gentoo-8b1e7fd32b497092bbe578e3bedd0e5fe0bcca8d.zip
dev-python/twine: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/twine-1.15.0.ebuild11
-rw-r--r--dev-python/twine/twine-3.1.1.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/dev-python/twine/twine-1.15.0.ebuild b/dev-python/twine/twine-1.15.0.ebuild
index c306897ff28f..685e99a4a62d 100644
--- a/dev-python/twine/twine-1.15.0.ebuild
+++ b/dev-python/twine/twine-1.15.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
@@ -15,15 +16,15 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm64 ~hppa ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+DEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
)
"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
>=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
>=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
@@ -32,8 +33,6 @@ RDEPEND="${CDEPEND}
$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5})
"
-RESTRICT="!test? ( test )"
-
PATCHES=(
"${FILESDIR}/twine-1.15.0-tests.patch"
)
diff --git a/dev-python/twine/twine-3.1.1.ebuild b/dev-python/twine/twine-3.1.1.ebuild
index 6b1e17bcd56a..7217eb645273 100644
--- a/dev-python/twine/twine-3.1.1.ebuild
+++ b/dev-python/twine/twine-3.1.1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -15,9 +16,9 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${CDEPEND}
+BDEPEND="
test? (
dev-python/jaraco-envs[${PYTHON_USEDEP}]
dev-python/jaraco-functools[${PYTHON_USEDEP}]
@@ -28,7 +29,7 @@ BDEPEND="${CDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)
"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
>=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
>=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
@@ -38,8 +39,6 @@ RDEPEND="${CDEPEND}
>=dev-python/keyring-15.1[${PYTHON_USEDEP}]
"
-RESTRICT="!test? ( test )"
-
PATCHES=(
"${FILESDIR}/twine-3.0.0-tests.patch"
)