summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 23:52:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 00:21:01 +0100
commitbbb273f8827cdf1198548c7bdd1951b08e6b71bf (patch)
treefc52b9ffbe5019e118ad7b386d0b2f6218305c9d /dev-python/twine
parentdev-python/google-api-core: Bump to 2.5.0 (diff)
downloadgentoo-bbb273f8827cdf1198548c7bdd1951b08e6b71bf.tar.gz
gentoo-bbb273f8827cdf1198548c7bdd1951b08e6b71bf.tar.bz2
gentoo-bbb273f8827cdf1198548c7bdd1951b08e6b71bf.zip
dev-python/twine: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-3.8.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 33dfb19f6a54..c9396c74d67c 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1 +1,2 @@
DIST twine-3.7.0.tar.gz 212591 BLAKE2B 116d96a058cb53e0626747aaeae40c63fd6ece4ed8ef537c3890f99226f34827b65e5e894f5f04a24999d5ca2bcf182505e08075c4ff8b979d7be71e05f645ef SHA512 d7ddfdfcbaa7a5e3eba3657a06da090eeecbf373646e64d659f420fae4ba10c16c2c02e85bdf9c1f050b86177f19c85aa20183ad9d546cb053a11d60db0851f3
+DIST twine-3.8.0.tar.gz 213157 BLAKE2B c7c013a01b0f1f5ec24c76ebfea2c645da07eae0bb816978a37ed95bca4a2193cea627bdddefcd4beaadbe4bd7ee51315b309fbf06555cc75d509bc61578ac7d SHA512 d6ede7241d4825665054811ad657916281426eda6ee88f0e83295b5498876830b6c69284056e409539c792c24ebeb5af2eedf45108261490a72812b9e86e08f2
diff --git a/dev-python/twine/twine-3.8.0.ebuild b/dev-python/twine/twine-3.8.0.ebuild
new file mode 100644
index 000000000000..77e8f4fd95be
--- /dev/null
+++ b/dev-python/twine/twine-3.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}