summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-25 05:46:46 +0000
committerSam James <sam@gentoo.org>2021-11-25 05:46:46 +0000
commitfb38a0a3095354be9834a4332390722ceaf9103a (patch)
treebeae978c461ca99707d2da6a79c37e37a9652e18 /dev-python/twine
parentdev-python/twine: add 3.6.0 (diff)
downloadgentoo-fb38a0a3095354be9834a4332390722ceaf9103a.tar.gz
gentoo-fb38a0a3095354be9834a4332390722ceaf9103a.tar.bz2
gentoo-fb38a0a3095354be9834a4332390722ceaf9103a.zip
dev-python/twine: drop 3.5.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-3.5.0.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index e3b6ac1d0370..6f7d9ec6e5a8 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,3 +1,2 @@
DIST twine-3.4.2.tar.gz 212266 BLAKE2B 602bb72f4be1c0d28341fb3378a5d55737c14555495640ae3414a1c8e7ca0c06b2c2ce3c358130251c02f0a51b61eb362a1e999c3945d4d1d7afd7bcd4d17807 SHA512 3f6d8992294a35e2a26be64f56c88d31af63b05f3f477d545bc82d928ca1b9939d23fa489eca5232502a49def77d489eaf6a29663d150f78b5cdb99749ff9b50
-DIST twine-3.5.0.tar.gz 211946 BLAKE2B 7ec2eb88a4496f7e750927c83b2e6d6ed39a08bb1775cda8df555ee6ce5244d721e8aaf2d983f983219b9445f56e2a830979a5e5e6165ab7e6ec12b2a0602842 SHA512 37219c1078bb7209123aee79c2d2bd73390c8ce4ab2bf6b5493a54e4ccb9c714a6422ee4a782b3c19d3a5344c1431285c666230729f44615b7761c7a5aff07d6
DIST twine-3.6.0.tar.gz 211971 BLAKE2B 763f021e374c86749bca77ca67a5fe534acf333464d6cc2f978de4625abc09b7574aa31de927300983eb6feb801e77a169f11deb4edc5036df73943778f5844d SHA512 41da4d89ac69c692a98545aefffd9afd4c7b0287179807906504b4121bf9257095b227ec2966d98983939fa76fb8509f6ffa2577c0e7b4c7f43f614f44745460
diff --git a/dev-python/twine/twine-3.5.0.ebuild b/dev-python/twine/twine-3.5.0.ebuild
deleted file mode 100644
index 97a82eff44d7..000000000000
--- a/dev-python/twine/twine-3.5.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Collection of utilities for publishing packages on PyPI"
-HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
-SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
- >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
- >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
- >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/jaraco-envs[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/munch[${PYTHON_USEDEP}]
- dev-python/portend[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- # requires internet
- rm -f tests/test_integration.py || die
- # pytest-socket dep relevant only to test_integration, and upstream
- # disables it anyway
- sed -i -e '/--disable-socket/d' pytest.ini || die
- sed -i -e '/--cov/d' pytest.ini || die
-
- distutils-r1_python_prepare_all
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}