summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-23 08:48:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 09:12:13 +0100
commit3148a9b2620b6155a0b6bbfdfd44ab92e3f5852d (patch)
tree016f8a7b8cdae64dcec3c5d089202747344af4c9 /dev-python/typeguard
parentdev-python/Faker: Bump to 9.8.3 (diff)
downloadgentoo-3148a9b2620b6155a0b6bbfdfd44ab92e3f5852d.tar.gz
gentoo-3148a9b2620b6155a0b6bbfdfd44ab92e3f5852d.tar.bz2
gentoo-3148a9b2620b6155a0b6bbfdfd44ab92e3f5852d.zip
dev-python/typeguard: Bump to 2.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-2.13.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 8494b7e8fe25..baa4b0e55eee 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-2.13.0.gh.tar.gz 36849 BLAKE2B ef9b724bdd5ef127b6ede4ff4cb1d4f4794b0e921512d2cbf474145bf64de0cae85b7f5283dfc7f0b750e79e1c44c03ce6b4c0f24a33ae961c428aa57f3b6ae5 SHA512 48df7a9d6ee2cc11b5118432afcda5e0939712ff66d67f3945e26047c0880a05c133b505869ebcef59ce438260b9f6d1806121d0d4828853bc3b9c3468769f39
+DIST typeguard-2.13.2.gh.tar.gz 37142 BLAKE2B 0aa3f53bc0d1aa485d071cd52d2458ab83c4d5eba88708240c100a3205a2714f39465cb48d82118eb6bcf1e30579e50bb5dffb31b3f2b673573481772d650a23 SHA512 a11c1b9ee417a99a8bd09f4b5b05c7cdf319748b8221a49d1ff76854e2f432768224437f82a41c0166e5b148a550b58afbabfa1935cdc2a049cda3010edd052a
diff --git a/dev-python/typeguard/typeguard-2.13.2.ebuild b/dev-python/typeguard/typeguard-2.13.2.ebuild
new file mode 100644
index 000000000000..9ea46fa44506
--- /dev/null
+++ b/dev-python/typeguard/typeguard-2.13.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/"
+SRC_URI="
+ https://github.com/agronholm/typeguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ epytest
+}