summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-02 15:58:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-02 16:03:12 +0200
commit52bae50c35f05f1d64ff086291603f1a606afd89 (patch)
treec6d1b4dede3d9b7a1ef6238581a1eb0ed9ffc10a /dev-python/ujson
parentdev-python/hypothesis: add 6.59.0 (diff)
downloadgentoo-52bae50c35f05f1d64ff086291603f1a606afd89.tar.gz
gentoo-52bae50c35f05f1d64ff086291603f1a606afd89.tar.bz2
gentoo-52bae50c35f05f1d64ff086291603f1a606afd89.zip
dev-python/ujson: add 5.6.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-5.6.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 0874b136e850..1e6928ca6ef7 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1 +1,2 @@
DIST ujson-5.5.0.tar.gz 7140414 BLAKE2B cca99fbb8cec447500c0dec34a952c4474acd0149783c887ee713cee60859570e41c9e349d49ff7eeba645d0c04a7e368da2ec8c42b6f55f59e971f834449e3a SHA512 883c0bd8b933557fc98556af1679de6df0372ee83a5533d8ea3f994dc13cd9bcd3140e2532ea1ad24419dab9ffbb59027e00f0a5e7ca285bf68358205a07bcd5
+DIST ujson-5.6.0.tar.gz 7151977 BLAKE2B 59c0b88bdc59791889971993135484ce99763ad4805b36db7a3abc5e950c9132b917e7fbfb09870af916f5939d10e23ab44137f416179f75a06f424cf4b1154d SHA512 996c9746e011f116fcab3e61345df27cb2c1251852f758eff1d3465e19df03deb1a037669aa6ee5aad2fc6c2cf76c22075ad6a73158ff4dc81357e59a4ee244a
diff --git a/dev-python/ujson/ujson-5.6.0.ebuild b/dev-python/ujson/ujson-5.6.0.ebuild
new file mode 100644
index 000000000000..ca2f1fe67e94
--- /dev/null
+++ b/dev-python/ujson/ujson-5.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="
+ https://github.com/ultrajson/ultrajson/
+ https://pypi.org/project/ujson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/double-conversion:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export UJSON_BUILD_DC_INCLUDES="${EPREFIX}/usr/include/double-conversion"
+ export UJSON_BUILD_DC_LIBS="-ldouble-conversion"
+ export UJSON_BUILD_NO_STRIP=1
+}