summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-14 14:22:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-14 14:22:26 +0100
commit12f48f026bc0c124bf5e7baa1a638441c7e6d269 (patch)
treeeba36c723f268e43042103721b17538916798384 /dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild
parentvirtualbox packages: Security cleanup (bug #607674). (diff)
downloadgentoo-12f48f026bc0c124bf5e7baa1a638441c7e6d269.tar.gz
gentoo-12f48f026bc0c124bf5e7baa1a638441c7e6d269.tar.bz2
gentoo-12f48f026bc0c124bf5e7baa1a638441c7e6d269.zip
dev-python/urdf_parser_py: Bump to 0.3.3 and add python 3.4/3.5 support.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild')
-rw-r--r--dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild b/dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild
new file mode 100644
index 000000000000..a2bfe2811f60
--- /dev/null
+++ b/dev-python/urdf_parser_py/urdf_parser_py-0.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="URDF parser for Python"
+HOMEPAGE="http://wiki.ros.org/urdfdom_py"
+SRC_URI="https://github.com/ros/urdf_parser_py/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"