summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 09:29:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-26 10:41:30 +0100
commitce9fd297c7434fbe409440a054bee6efd526ef41 (patch)
tree4826bca28120775a8a223ad8a2378c923240920d /dev-python/urllib3
parentdev-python/requests: Remove old (diff)
downloadgentoo-ce9fd297c7434fbe409440a054bee6efd526ef41.tar.gz
gentoo-ce9fd297c7434fbe409440a054bee6efd526ef41.tar.bz2
gentoo-ce9fd297c7434fbe409440a054bee6efd526ef41.zip
dev-python/urllib3: Remove old
Bug: https://bugs.gentoo.org/776421 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.25.11.ebuild69
-rw-r--r--dev-python/urllib3/urllib3-1.26.3-r1.ebuild71
3 files changed, 0 insertions, 142 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 6eaf5b841ba6..6ff68cf07a9e 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1 @@
-DIST urllib3-1.25.11.tar.gz 260300 BLAKE2B 06bd2107bad479e36c6474f95567c3ecb119d18b193b358df9e345e4d09392366255b21597b26fbf2374220b921cc2117a1972f88021c3a6ebac3844a319acbe SHA512 58f77edb9ced62cbac7b0baf2651c07f9f413267f103730ee25f08c5d4d0bf52a2ace02f58841bcd55652db677c7a1dc9a756681e7e32d590bc69d8b93e8f173
-DIST urllib3-1.26.3.tar.gz 292598 BLAKE2B 31bcf03debd74a65004484f12c9ad4d71b8c065344f1e377c2f4a695fc0778cf4cb503dbe243133a20d5779ba4bea455213c62aa5dc3815a994acb4e0adf46b6 SHA512 d0dde67880212dc134add3e16e0aa391170963ed26b9a7eb65399235251131ce25488268df7b2f933afc71c9a94e55e08404f9326c0bf5142869dac912d3ee01
DIST urllib3-1.26.4.tar.gz 293008 BLAKE2B 6ca88861baa87814d3856cd0f1fa0a6cb9e11ee745c782b598c4f5fe74b195ba47e8430b993ed8a5fb269153d700e4a803cd2ebc177e20e3186b3b26612262c7 SHA512 daf2ba432f2e4edaa6aa8c6bdaaea21fcb77cc5fdfd991f89b1f753b4f9901faab04120841e9fa8d93e2bd3d72cbdb647f1492d882266b4e0281c725e8d55a7a
diff --git a/dev-python/urllib3/urllib3-1.25.11.ebuild b/dev-python/urllib3/urllib3-1.25.11.ebuild
deleted file mode 100644
index 772a892ba7d7..000000000000
--- a/dev-python/urllib3/urllib3-1.25.11.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlipy[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{6,7,8,9})
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/alabaster \
- dev-python/mock
-
-python_prepare_all() {
- # https://github.com/urllib3/urllib3/issues/1756
- sed -e 's:10.255.255.1:240.0.0.0:' \
- -i test/__init__.py || die
- # tests failing if 'localhost.' cannot be resolved
- sed -e 's:test_dotted_fqdn:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- case ${EPYTHON} in
- python3*)
- pytest -vv || die "Tests fail with ${EPYTHON}"
- ;;
- esac
-}
diff --git a/dev-python/urllib3/urllib3-1.26.3-r1.ebuild b/dev-python/urllib3/urllib3-1.26.3-r1.ebuild
deleted file mode 100644
index 25ba58bf0bf0..000000000000
--- a/dev-python/urllib3/urllib3-1.26.3-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{6,7,8,9})
- )
-"
-
-python_prepare_all() {
- # https://github.com/urllib3/urllib3/issues/1756
- sed -e 's:10.255.255.1:240.0.0.0:' \
- -i test/__init__.py || die
- # upstream requires updates to this periodically. seriously?!
- sed -e '/RECENT_DATE/s:date(.*):date(2020, 7, 1):' \
- -i src/urllib3/connection.py || die
- # tests failing if 'localhost.' cannot be resolved
- sed -e 's:test_dotted_fqdn:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- [[ ${EPYTHON} == python3* ]] || continue
-
- local deselect=(
- # TODO?
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- )
-
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests fail with ${EPYTHON}"
-}