summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElvis Pranskevichus <elvis@magic.io>2017-10-02 14:30:33 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-10-03 00:02:57 +0200
commit1c3ea49bbb806700a29de86b32383dca1fecca34 (patch)
tree02fd3161ceae940bd6af00d43e4f456e779c26e9 /dev-python/uvloop/uvloop-0.8.1.ebuild
parentapp-editors/atom: version bump to 1.20.1. (diff)
downloadgentoo-1c3ea49bbb806700a29de86b32383dca1fecca34.tar.gz
gentoo-1c3ea49bbb806700a29de86b32383dca1fecca34.tar.bz2
gentoo-1c3ea49bbb806700a29de86b32383dca1fecca34.zip
dev-python/uvloop: version bump to 0.8.1.
Package-Manager: Portage-2.3.8, Repoman-2.3.1 Closes: https://bugs.gentoo.org/601918 Closes: https://github.com/gentoo/gentoo/pull/5839
Diffstat (limited to 'dev-python/uvloop/uvloop-0.8.1.ebuild')
-rw-r--r--dev-python/uvloop/uvloop-0.8.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/uvloop/uvloop-0.8.1.ebuild b/dev-python/uvloop/uvloop-0.8.1.ebuild
new file mode 100644
index 000000000000..fd91fc222426
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-libs/libuv-1.11.0:="
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ cat <<EOF >> setup.cfg
+[build_ext]
+use-system-libuv=1
+EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_ext --inplace build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+ distutils-r1_python_install_all
+}