summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-16 10:37:15 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-16 10:53:45 +0200
commit1ecaa0bf3e40bf85676299dec59fb7684584f107 (patch)
tree30b370f35f3e02d64880327205e3fa2dcb06405f /dev-python/vcrpy
parentdev-python/wrapt: Add pypy support (diff)
downloadgentoo-1ecaa0bf3e40bf85676299dec59fb7684584f107.tar.gz
gentoo-1ecaa0bf3e40bf85676299dec59fb7684584f107.tar.bz2
gentoo-1ecaa0bf3e40bf85676299dec59fb7684584f107.zip
dev-python/vcrpy: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-1.7.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 9a8b1c540b53..0a34c001292b 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-1.5.2.tar.gz 299525 SHA256 ef3216e91ab3a51b67c44e0e4a8c50f6edcc812658da4c73ff32b1eb36a8a9bf SHA512 2eccc061a1e90b03fb0688aac5566bdf96a7bfd6ffc34aa71af8395665cde8f183d02c5107572f1bbca0388c865c913f1b2a9c7b295c11be395dce20c4d5b761 WHIRLPOOL 49a0eb2d582003bebb788129d5f03a8d120d9752867d439a7394e7ed664b6a1b296d59d5a501e861cf3e78e4679c7a6e683843d75a0e512d0e4185da196f6081
+DIST vcrpy-1.7.3.tar.gz 164928 SHA256 d10f10eb23f7a662ff6c637f2fd57bfed29d62a0211dfd6802767cfc5f0716a1 SHA512 338d168436438d13af09e969bb2bdfd49b62fe12f78b3899fd423c3221a0d194bb2c53e660d1e5fabd76dff27ba6eca1c5052e0bd40a995929de56614bbe13cd WHIRLPOOL 19e34d7ed9ea5ec99a34595f5f38859befe34ca33a0b853550c106ab91b891dde62ca1b1291a903cd17c8c96d81cd55536868dfe5486b5e716ded5685e5b3eb2
diff --git a/dev-python/vcrpy/vcrpy-1.7.3.ebuild b/dev-python/vcrpy/vcrpy-1.7.3.ebuild
new file mode 100644
index 000000000000..ee49dfff6c4f
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-1.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die
+}