summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-30 15:37:46 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-30 15:37:46 +0200
commit356e7c69b66c9a0a6807d82f8b678fe7a424c110 (patch)
treea99d1ee3bdb2a462c7ed132e76f6a61ff6de024a /dev-python/vcrpy
parentdev-libs/mongo-c-driver: fix building with libressl (bug #618988) (diff)
downloadgentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.tar.gz
gentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.tar.bz2
gentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.zip
dev-python/vcrpy: Version bump to 1.11.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-1.11.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 1e6205e73120..3700a2852775 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,4 @@
DIST vcrpy-1.10.3.tar.gz 61804 SHA256 b2c76736999d81d5321b94d997e3480ffbde8fe56d918eb2798d0e0545cb9f21 SHA512 976f3d9b58025ab5c3a8a666138fbbadccaf8612edea63ac4fbf307d55888eb688bf27dd0f24b0d2c5528c951ced533a52cf13c33bfb32d7e89f241ff508018d WHIRLPOOL 3ca8728d8347bd9ad41b84e27713322b1f567043ab2bcc1691aef985e8234a403147b688630a3915390d0f19d6119f268dadf3cd3ab8eb6b38e3acce40fe1a6b
DIST vcrpy-1.10.5.tar.gz 61656 SHA256 c70464484e036e6e9339df433bca813174e14828e42886622d416e2fcd63768a SHA512 9e643632b28b9dd53b35338eebec83f11aff3744416cfa5efbb2f3cd8674491a3c89270101a437a7290b2b4212390af16c1436f2342ebcba6a4d18965118a6c4 WHIRLPOOL 3d9534160545ed79f6dfb9dce9f87d4998b18d35d828aa99578ca38fa996dec9fa8b6cf9254aa8b11c979423efe4f9f2a4bcc23d538053edd642bc2284f4c5e2
DIST vcrpy-1.11.0.tar.gz 61029 SHA256 beb30de89c3618482ea76662b4135d48fef7417589df49c303b2e85db40c9705 SHA512 32db3ab3ba605792815ec1e4509f4ae7c6d6abff5cad82eb38e09b812628f58bdf04f1e09e22e66d926444a0808237d5df3c3955eb8567eb8f4d5e4684eda422 WHIRLPOOL 1a59cfd83cf7af1da555283bc7a8b122719ece036e1088811e7c667243cc31ea5b54bf103cc4f504b40fcce612f02a0c26e7d3b5136acf9f15cd916d8f88ba46
+DIST vcrpy-1.11.1.tar.gz 63122 SHA256 f434fe7e05d940d576ac850709ae57a738ba40e7f317076ea8d359ced5b32320 SHA512 d883b87d5b3017843dfc2e33241953ada27d50ffda4936ba4326a392acb9c7667474abd054d6e44b0208096cd96b68e87ec9780c0d6fab77369cc4e517617395 WHIRLPOOL 5bd432ea9e4b94f62a186ac986f1fa0647badb9afa0ce87d33fc4b4bc984edc1dce69e951ddad062792fcdfeeae9122ac090b546131c94969891a98a6bb1b7ce
diff --git a/dev-python/vcrpy/vcrpy-1.11.1.ebuild b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
new file mode 100644
index 000000000000..b50e9d02784c
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/yarl[${PYTHON_USEDEP}]' python3*)
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv -x tests/unit || die
+}