summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-05 00:35:47 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-05 00:35:47 +0200
commit99d342f2cbdac0768b9aaaacb0c1e17184aad67c (patch)
tree653d1ef61a5c1ed67ee1f4cc8389822a77646a15 /dev-python/vcrpy
parentapp-editors/retext: Update dependencies (diff)
downloadgentoo-99d342f2cbdac0768b9aaaacb0c1e17184aad67c.tar.gz
gentoo-99d342f2cbdac0768b9aaaacb0c1e17184aad67c.tar.bz2
gentoo-99d342f2cbdac0768b9aaaacb0c1e17184aad67c.zip
dev-python/vcrpy: Version bump to 1.10.0, add python3_5
Gentoo-Bug: 590538 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-1.10.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 478fdebb5513..52a78ace1e1d 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,4 @@
+DIST vcrpy-1.10.0.tar.gz 61035 SHA256 f64ad26e06c3b45465044c03555bc69a077822432ab839118963229c4ef63e81 SHA512 77049224b618a100d371df9441de1e9cb06b8c3d415be4f8b333387da90a318986f705740ec19764c89eb937ff47f9dd1692d0a884403804b87db160604bddfb WHIRLPOOL ba48abce4344091f6fc795568e08a655e6b7f358f0af031218a036eb81761dbf5edf16c3834b12da2fa1a2cac33dea9940862d1bab68ad85c7adcb8399b7edbe
DIST vcrpy-1.5.2.tar.gz 299525 SHA256 ef3216e91ab3a51b67c44e0e4a8c50f6edcc812658da4c73ff32b1eb36a8a9bf SHA512 2eccc061a1e90b03fb0688aac5566bdf96a7bfd6ffc34aa71af8395665cde8f183d02c5107572f1bbca0388c865c913f1b2a9c7b295c11be395dce20c4d5b761 WHIRLPOOL 49a0eb2d582003bebb788129d5f03a8d120d9752867d439a7394e7ed664b6a1b296d59d5a501e861cf3e78e4679c7a6e683843d75a0e512d0e4185da196f6081
DIST vcrpy-1.7.3.tar.gz 164928 SHA256 d10f10eb23f7a662ff6c637f2fd57bfed29d62a0211dfd6802767cfc5f0716a1 SHA512 338d168436438d13af09e969bb2bdfd49b62fe12f78b3899fd423c3221a0d194bb2c53e660d1e5fabd76dff27ba6eca1c5052e0bd40a995929de56614bbe13cd WHIRLPOOL 19e34d7ed9ea5ec99a34595f5f38859befe34ca33a0b853550c106ab91b891dde62ca1b1291a903cd17c8c96d81cd55536868dfe5486b5e716ded5685e5b3eb2
DIST vcrpy-1.7.4.tar.gz 191306 SHA256 c558f50c20ec7a3e5d5d71c0e9701518dff959736f2a8e7f1f98798354e44e6e SHA512 978c881a694368e9382d6426f990a844910afb6b7777e5226e98a10d2848e09e8c90ffc35250013b5f470577ea6565117d728673456c88aa871444d5db84892a WHIRLPOOL 222b2b2147510cce9ecf18cfb4366f4ccaaf861485b96bd8ed560a9a87d9e5edcf92b265cc65adbf5d59d4462ed6d44d96521f1b981690752fe1fd9f88fc8eb2
diff --git a/dev-python/vcrpy/vcrpy-1.10.0.ebuild b/dev-python/vcrpy/vcrpy-1.10.0.ebuild
new file mode 100644
index 000000000000..f95556b6dd76
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-1.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )"
+
+# Calls to the net
+RESTRICT=test
+
+python_test() {
+ py.test -vv -x || die
+}