summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 23:35:51 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 23:35:51 +0200
commitcc95113565598b91d8e8fb5a2c70c6b0b29e5025 (patch)
treefbfa704d42e12eb90167371fae73dc5bbb9b5293 /dev-python/vcrpy
parentapp-emulation/containerd: Add snapshot for docker-17.05.0_rc1 (diff)
downloadgentoo-cc95113565598b91d8e8fb5a2c70c6b0b29e5025.tar.gz
gentoo-cc95113565598b91d8e8fb5a2c70c6b0b29e5025.tar.bz2
gentoo-cc95113565598b91d8e8fb5a2c70c6b0b29e5025.zip
dev-python/vcrpy: Version bump to 1.10.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-1.10.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index be5b812285eb..49a9e428dda1 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,2 +1,3 @@
DIST vcrpy-1.10.3.tar.gz 61804 SHA256 b2c76736999d81d5321b94d997e3480ffbde8fe56d918eb2798d0e0545cb9f21 SHA512 976f3d9b58025ab5c3a8a666138fbbadccaf8612edea63ac4fbf307d55888eb688bf27dd0f24b0d2c5528c951ced533a52cf13c33bfb32d7e89f241ff508018d WHIRLPOOL 3ca8728d8347bd9ad41b84e27713322b1f567043ab2bcc1691aef985e8234a403147b688630a3915390d0f19d6119f268dadf3cd3ab8eb6b38e3acce40fe1a6b
+DIST vcrpy-1.10.5.tar.gz 61656 SHA256 c70464484e036e6e9339df433bca813174e14828e42886622d416e2fcd63768a SHA512 9e643632b28b9dd53b35338eebec83f11aff3744416cfa5efbb2f3cd8674491a3c89270101a437a7290b2b4212390af16c1436f2342ebcba6a4d18965118a6c4 WHIRLPOOL 3d9534160545ed79f6dfb9dce9f87d4998b18d35d828aa99578ca38fa996dec9fa8b6cf9254aa8b11c979423efe4f9f2a4bcc23d538053edd642bc2284f4c5e2
DIST vcrpy-1.7.4.tar.gz 191306 SHA256 c558f50c20ec7a3e5d5d71c0e9701518dff959736f2a8e7f1f98798354e44e6e SHA512 978c881a694368e9382d6426f990a844910afb6b7777e5226e98a10d2848e09e8c90ffc35250013b5f470577ea6565117d728673456c88aa871444d5db84892a WHIRLPOOL 222b2b2147510cce9ecf18cfb4366f4ccaaf861485b96bd8ed560a9a87d9e5edcf92b265cc65adbf5d59d4462ed6d44d96521f1b981690752fe1fd9f88fc8eb2
diff --git a/dev-python/vcrpy/vcrpy-1.10.5.ebuild b/dev-python/vcrpy/vcrpy-1.10.5.ebuild
new file mode 100644
index 000000000000..a0e580c663bd
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-1.10.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/yarl[${PYTHON_USEDEP}]' python3*)
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv -x tests/unit || die
+}