summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-30 01:06:56 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-05-30 07:47:41 +0000
commit71d2ffb5e781c00bc3c58e4f158c0256f37a4aea (patch)
tree22c9bd38720fef1052483fd2c4f66555315fbcb5 /dev-python/visitor
parentwww-client/chromium: x86 stable wrt bug #584310 (diff)
downloadgentoo-71d2ffb5e781c00bc3c58e4f158c0256f37a4aea.tar.gz
gentoo-71d2ffb5e781c00bc3c58e4f158c0256f37a4aea.tar.bz2
gentoo-71d2ffb5e781c00bc3c58e4f158c0256f37a4aea.zip
dev-python/visitor: bump to 0.1.3
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1558 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/visitor')
-rw-r--r--dev-python/visitor/Manifest1
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/visitor/Manifest b/dev-python/visitor/Manifest
index f3c6e79560f4..1bccc3cbd51d 100644
--- a/dev-python/visitor/Manifest
+++ b/dev-python/visitor/Manifest
@@ -1 +1,2 @@
DIST visitor-0.1.2.tar.gz 2957 SHA256 ff8c6231aa4a63c9f52f0d7eeedeb8561f847c4514753a9db33906296375c046 SHA512 3251e8c81673a7ded8eecd68bdc6294e4b386bfe6118280db0bac908b835aa1823cc0b470a6d69432f89821c6275afbe8c295da21edd1d10db3b8757727c43dd WHIRLPOOL 69f4d0344f3ca8ccd848bcf8ed848887c8845210dd8b9e09efa138ada5789b8c38f4a0e46e028be4b643e745d539f3a1cdf51d6b51688a97bc91146525c91a55
+DIST visitor-0.1.3.tar.gz 2985 SHA256 eaefe1cfc3b40b2a54579b028230a1ea1cf1cb884b7a347b7350a18cf37e8019 SHA512 414c77df8efcc22df5ee8073e02b8c5c28563954ef9b9a869c4ea3f7f1268a97929c1fe29142ba41e3a5acafea52599f6bf073aacd654643d7d8380cd4f41fbc WHIRLPOOL 6e436e9d8e8d68ca3d891022eb8c9c2182ec3c37d24cf543aefb78330f7d5fd1c4363f4a6b9a16c5a6bd8c63d676a27aabf770d27a266f4c8f4f7e4b22bf91ed
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
new file mode 100644
index 000000000000..0d1c1bf207f7
--- /dev/null
+++ b/dev-python/visitor/visitor-0.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tiny pythonic visitor implementation"
+HOMEPAGE="https://github.com/mbr/visitor"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/visitor/pull/2
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}