summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-16 14:07:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-16 14:07:00 +0200
commit37cc1f11ce22a96933b89ec8e7843b17bdb79e1d (patch)
tree7ce1ae953ed5471f18f6e2ad2d092cb2397b6c8d /dev-python/waitress
parentdev-python/socketpool: Add python3_6 (diff)
downloadgentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.tar.gz
gentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.tar.bz2
gentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.zip
dev-python/waitress: Version bump to 1.0.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/Manifest1
-rw-r--r--dev-python/waitress/waitress-1.0.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/waitress/Manifest b/dev-python/waitress/Manifest
index 9fc4ea4a8694..11f987f72163 100644
--- a/dev-python/waitress/Manifest
+++ b/dev-python/waitress/Manifest
@@ -1 +1,2 @@
DIST waitress-1.0.1.tar.gz 123934 SHA256 2daacaece189ede6a23440afe03bda58089a6207f1d80a1e9497f979dfb741fc SHA512 0205a0a5fc9e65e20370fc1e97ba456337313c93817e9b2b283610e5045eb32de80f45d19ee0cfb9469a93e4fc9267b785feacedd70b362474f4af5c05a3ab21 WHIRLPOOL 0eca4eec79b894fb561a894f26de1adbe45c70335c66f589d66b26d9c68a708c443eaacded46099d23401390ee45743b8fa2bc39e744f61a988f6695e8c83ea4
+DIST waitress-1.0.2.tar.gz 124685 SHA256 c74fa1b92cb183d5a3684210b1bf0a0845fe8eb378fa816f17199111bbf7865f SHA512 b7000e1198ac306ce189f70c5dcfcf41318e5ec47c8d6183cdbc360c8759ca726405d5da70f1c7fe3cfeb39d528af94d693767c2a7a1a7fe460c6407857ec6f0 WHIRLPOOL cb8f6c3602540e5978c10218eef52c88a711855097f2ea646c8ccdc12c89b9df642dce994b17b1e8bbd9bbf8b18d6be2da506eebe3201e63b895207c1af9407b
diff --git a/dev-python/waitress/waitress-1.0.2.ebuild b/dev-python/waitress/waitress-1.0.2.ebuild
new file mode 100644
index 000000000000..7d407a99d663
--- /dev/null
+++ b/dev-python/waitress/waitress-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="http://docs.pylonsproject.org/projects/waitress/en/latest/ https://pypi.python.org/pypi/waitress/ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}