summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-03 07:28:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-03 07:42:58 +0100
commit42957501b336c5ee8a3d87c9419d92a39131a814 (patch)
tree9526834be52f3b9d8cccc1f306646bca146a52a8 /dev-python/wcmatch
parentdev-python/backrefs: Bump to 5.2 (diff)
downloadgentoo-42957501b336c5ee8a3d87c9419d92a39131a814.tar.gz
gentoo-42957501b336c5ee8a3d87c9419d92a39131a814.tar.bz2
gentoo-42957501b336c5ee8a3d87c9419d92a39131a814.zip
dev-python/wcmatch: Bump to 8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/wcmatch-8.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index f72ef09386d9..de2f81d5d20a 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1 +1,2 @@
DIST wcmatch-8.2.tar.gz 113537 BLAKE2B d1fe53f7d2394af31750c0b98451749201b1adbd8d00a734418afd8e208a9480b913059f78f62016be2fc2109813406c096f8ab60973a716b6ca275377551281 SHA512 d56d868ec0578ae59eb5f39ff17005faed13162141e3ced15c60d8de5f8e8b1a16eaf66e7c73cffdbd288b94db57843112624de8e5b588d26a5e46d4edb72168
+DIST wcmatch-8.3.tar.gz 116600 BLAKE2B 8576a546278a69ba46af262bc925370e6d8b1828975d54fe3fe1a2e39fc8456134c7f7986e1674883ca0f0298c223be7efc67c7296a29d9a4f1b64e42614ce17 SHA512 64cd84e69ceb6c5953f281711d026540ac198256cda3ca32c90d2acb01b18c93ceaebd3440b395c3e77fc7ec38f350821b0095518ab5c065e698cfe0f2df4c1b
diff --git a/dev-python/wcmatch/wcmatch-8.3.ebuild b/dev-python/wcmatch/wcmatch-8.3.ebuild
new file mode 100644
index 000000000000..61d6e0564f4d
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}