summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:33:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:33 +0100
commit214ca91552605f96889b85e92f43ec7fde919324 (patch)
tree22f3d2af72b4dbb3ed3015a36ac13be96e12b238 /dev-python/weasyprint
parentdev-python/importlib_metadata: Bump to 4.11.2 (diff)
downloadgentoo-214ca91552605f96889b85e92f43ec7fde919324.tar.gz
gentoo-214ca91552605f96889b85e92f43ec7fde919324.tar.bz2
gentoo-214ca91552605f96889b85e92f43ec7fde919324.zip
dev-python/weasyprint: Bump to 54.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-54.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index b94c8f29ae6c..6e79672cdfdf 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,4 @@
DIST weasyprint-53.3.tar.gz 387448 BLAKE2B bc575a150ce3af4b33dc36b1d4148d5059c8a61c2576b9305735ae192314d7df61bd9c92defaa65159933be489c262e8ac343090a840d1cf49ed5af1e5e669ad SHA512 28efd97c06572de3e82763400efee3d2415da03feafcb38158c35465823d6ee8df9be4e11b813beeb2e851a6affae668ee9eea8859ec5de6c4da9347d9f4216a
DIST weasyprint-53.4.tar.gz 388163 BLAKE2B c4a15be4f11f7d6be1bc96da39defb3420f0e96181998f0f20a1da94ea2c942fd1b23f0c4257da122647a88c6950c519b01910476711d4b482a8a9ae0354d95c SHA512 7fcdedbecfa13434217b08491db62b9afd3e716d4ac6378490a04120c407ab1b20883227c32a77c9bd8c8dd7324fb505920264db3c9105d712fa4d7dcf3a1578
DIST weasyprint-54.0.tar.gz 402453 BLAKE2B 57c086a0ddf71e5eecf3860f5efcac327c927689e726694d59122a1ad6e7065c828497eacc04866bd4896a12016a75fc227e5f278f7ee987c8c489db3f7474c4 SHA512 3f6595fa856a5ef97e6c0009de34c3c614b829618fc9a28d5728047bbb6edf4972576a5577ef57d588a645d09a76e87ceb8928cc5536fb3900e6525559bf643b
+DIST weasyprint-54.2.tar.gz 403906 BLAKE2B 47fae441ed7186d30de3c32d20fc9503624b06ee5b6a76ec499914852e198b8e85234a779e5f96a48dc310883b8870afea734006dc2a20545537ad66ceff435f SHA512 fd7d07085f104958872a7ccf82d3ffc748936a4fd2d7757847b54de5248e1517a5f244b406cb052c809daa8194d0fa0701e05703b66afe8a809eff70d2cde8f3
diff --git a/dev-python/weasyprint/weasyprint-54.2.ebuild b/dev-python/weasyprint/weasyprint-54.2.ebuild
new file mode 100644
index 000000000000..b59226baf8d9
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-54.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}