summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-08 18:39:26 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-08 18:57:07 +0200
commit5e30f2dc6df1d092a998ab9cc95e045de501a105 (patch)
tree2864ca68a8309ecbbde7b5b6ce9841b7266c0bdf /dev-python/weasyprint
parentdev-python/blockdiag: Remove old (diff)
downloadgentoo-5e30f2dc6df1d092a998ab9cc95e045de501a105.tar.gz
gentoo-5e30f2dc6df1d092a998ab9cc95e045de501a105.tar.bz2
gentoo-5e30f2dc6df1d092a998ab9cc95e045de501a105.zip
dev-python/weasyprint: add 54.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-54.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 54ea11ed58b7..b94c8f29ae6c 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,2 +1,3 @@
DIST weasyprint-53.3.tar.gz 387448 BLAKE2B bc575a150ce3af4b33dc36b1d4148d5059c8a61c2576b9305735ae192314d7df61bd9c92defaa65159933be489c262e8ac343090a840d1cf49ed5af1e5e669ad SHA512 28efd97c06572de3e82763400efee3d2415da03feafcb38158c35465823d6ee8df9be4e11b813beeb2e851a6affae668ee9eea8859ec5de6c4da9347d9f4216a
DIST weasyprint-53.4.tar.gz 388163 BLAKE2B c4a15be4f11f7d6be1bc96da39defb3420f0e96181998f0f20a1da94ea2c942fd1b23f0c4257da122647a88c6950c519b01910476711d4b482a8a9ae0354d95c SHA512 7fcdedbecfa13434217b08491db62b9afd3e716d4ac6378490a04120c407ab1b20883227c32a77c9bd8c8dd7324fb505920264db3c9105d712fa4d7dcf3a1578
+DIST weasyprint-54.0.tar.gz 402453 BLAKE2B 57c086a0ddf71e5eecf3860f5efcac327c927689e726694d59122a1ad6e7065c828497eacc04866bd4896a12016a75fc227e5f278f7ee987c8c489db3f7474c4 SHA512 3f6595fa856a5ef97e6c0009de34c3c614b829618fc9a28d5728047bbb6edf4972576a5577ef57d588a645d09a76e87ceb8928cc5536fb3900e6525559bf643b
diff --git a/dev-python/weasyprint/weasyprint-54.0.ebuild b/dev-python/weasyprint/weasyprint-54.0.ebuild
new file mode 100644
index 000000000000..93af36f9311c
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-54.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}