summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-28 08:17:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-28 08:53:39 +0200
commita793d1b196c98f017324f5686b1161fa9d78f231 (patch)
tree710bae360c88921131be278fafe863d9d301a6a7 /dev-python/weasyprint
parentdev-python/hypothesis: Bump to 6.17.0 (diff)
downloadgentoo-a793d1b196c98f017324f5686b1161fa9d78f231.tar.gz
gentoo-a793d1b196c98f017324f5686b1161fa9d78f231.tar.bz2
gentoo-a793d1b196c98f017324f5686b1161fa9d78f231.zip
dev-python/weasyprint: Bump to 53.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-53.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 104a0e47050d..c8d1fc8c4f4a 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-53.0.tar.gz 386339 BLAKE2B 6d8e30a02d54061557e549a685944de7cbc61f4c1b46b23dbaef66e87232325f630fd5a34cf5c846599612914f9306b5235fad65a008e19a7c200af2f4c7d9da SHA512 de34ee5654ee90aec82b67c1bc7d9496fe3a4247b2a649ab110d1613c4780fd9ae611c9da177de07e5287749978af9a4a7d5c102d0940e5fd970e5aa8586c47e
+DIST weasyprint-53.2.tar.gz 387220 BLAKE2B 820c3ef386c86ab927a02153e68ba085817d18c9658539233c283b2ee2e58a190420a88d3d1b4282d7e46eefbd89d9c5fbd94ccefaa6ef7c304d893579739482 SHA512 c4e1a831a9ac5b3adf1241b8c53c90330e3960cf7a5ab8307bbeb89e8e17a7e5a5d50fd676961ce45deda606b82eaa2b05d37f7dd5a1506bd0d78f8e4276328a
diff --git a/dev-python/weasyprint/weasyprint-53.2.ebuild b/dev-python/weasyprint/weasyprint-53.2.ebuild
new file mode 100644
index 000000000000..f201ef75f8ef
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-53.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}