summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-02 16:32:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-02 16:32:50 +0100
commit4aad2cbceaab78816c169a78a1e3782935a7b717 (patch)
tree12e40a368ba82f968976f577fde33b309666cc34 /dev-python/websockets
parentllvm.org.eclass: Remove old snapshot hashes (diff)
downloadgentoo-4aad2cbceaab78816c169a78a1e3782935a7b717.tar.gz
gentoo-4aad2cbceaab78816c169a78a1e3782935a7b717.tar.bz2
gentoo-4aad2cbceaab78816c169a78a1e3782935a7b717.zip
dev-python/websockets: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/files/websockets-10.3-py311.patch24
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild39
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index ac0558fbdd12..84510f4c51eb 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,2 +1 @@
-DIST websockets-10.3.gh.tar.gz 304375 BLAKE2B db6075304613ff74ad5928a0c57e90a7d418ac0b9532adba4c6a17b3c3f1982cc94db8ac4c0da5f65343a915f3b2e7ccedce4e6d5d4960cb72fc93c3db6e041c SHA512 75a11dd7605808954c5f59decda5b115db73de96ed4023d8d7ee3c9966551a9ded2d771f76b086c76f49b0787f19349dadcd9010eb5fea8eeddf3d9bba1c6cbb
DIST websockets-10.4.gh.tar.gz 309611 BLAKE2B f3a739368ff9d78fef79324af59d1e77b3fb654b8b1a847373a29f19b11ae9266b9a938d235ee27d12b59d9b4cf29825fc7298ff2f35e5b260df2c7a41a1bd78 SHA512 087b1920ff26e21b8d3b80b53249d44b841fc45a4992df1ad725112404f724a41aaa2d759a2bd521dfe337459f8bf0d2ae048c423489f527c68f6825f928b582
diff --git a/dev-python/websockets/files/websockets-10.3-py311.patch b/dev-python/websockets/files/websockets-10.3-py311.patch
deleted file mode 100644
index d15eb2d32f81..000000000000
--- a/dev-python/websockets/files/websockets-10.3-py311.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/tests/legacy/test_client_server.py b/tests/legacy/test_client_server.py
-index f9de70c..05070c8 100644
---- a/tests/legacy/test_client_server.py
-+++ b/tests/legacy/test_client_server.py
-@@ -426,6 +426,10 @@ class CommonClientServerTests:
- self.used_for_read = True
- return super().recv(*args, **kwargs)
-
-+ def recv_into(self, *args, **kwargs):
-+ self.used_for_read = True
-+ return super().recv_into(*args, **kwargs)
-+
- def send(self, *args, **kwargs):
- self.used_for_write = True
- return super().send(*args, **kwargs)
-@@ -1299,6 +1303,8 @@ class ClientServerOriginTests(ClientServerTestsMixin, AsyncioTestCase):
- self.assertEqual(self.loop.run_until_complete(self.client.recv()), "Hello!")
-
-
-+@unittest.skipIf(sys.version_info[:2] >= (3, 11),
-+ "asyncio.coroutine has been removed in Python 3.11")
- class YieldFromTests(ClientServerTestsMixin, AsyncioTestCase):
- @with_server()
- def test_client(self):
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
deleted file mode 100644
index d71d754cb413..000000000000
--- a/dev-python/websockets/websockets-10.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/aaugustin/websockets/
- https://pypi.org/project/websockets/
-"
-SRC_URI="
- https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-py311.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # very fragile to speed
- tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
- )
-
- epytest tests
-}