summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-08 06:31:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-08 06:31:56 +0200
commit895a334117c8cf7759a135fcbe40322c71bc8633 (patch)
tree1a8490335e511c630d49e5e75d5680cd2b226aa8 /dev-python/websockets
parentdev-python/sphinx_ansible_theme: Bump to 0.10.2 (diff)
downloadgentoo-895a334117c8cf7759a135fcbe40322c71bc8633.tar.gz
gentoo-895a334117c8cf7759a135fcbe40322c71bc8633.tar.bz2
gentoo-895a334117c8cf7759a135fcbe40322c71bc8633.zip
dev-python/websockets: Bump to 11.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-11.0.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 56e0be59a9a8..e1ab4763d0f3 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,4 +1,5 @@
DIST websockets-10.4.gh.tar.gz 309611 BLAKE2B f3a739368ff9d78fef79324af59d1e77b3fb654b8b1a847373a29f19b11ae9266b9a938d235ee27d12b59d9b4cf29825fc7298ff2f35e5b260df2c7a41a1bd78 SHA512 087b1920ff26e21b8d3b80b53249d44b841fc45a4992df1ad725112404f724a41aaa2d759a2bd521dfe337459f8bf0d2ae048c423489f527c68f6825f928b582
DIST websockets-11.0.1.gh.tar.gz 347321 BLAKE2B 21ebcf13c41f5e7ea5247174684e8e37ac383fe94da7f6a1ebfeaf6024669fd2b362847055775a81cb4a36722526a42b91c9e28e1a8d016918ffe16481375f7b SHA512 a9c3bf215c5c5cf1032cf8f2cd85cc8d78e3486f4e40e301be246181dc64a5543377bc7205695f89f7141b2c48115cbcd1cca6a353ad9d36ac9cb294d48b2e2e
DIST websockets-11.0.2.gh.tar.gz 347575 BLAKE2B 1d609298d072dbd986fa2adcac1c8f80720622fdcd44cb8ab079ba812fa7a750cdd4a5b432a74d422ca3ac8e7baef8e38e227569b8681e033f599fa29b19383c SHA512 e397d7b51c3edcc68fd32dbf8fcd46f5c9230c270be46c45a503108690d5513e2626fc4f4f5d271c831570abeeff51bf27c09ea69459b970a41fb64eb84fc87e
+DIST websockets-11.0.3.gh.tar.gz 347652 BLAKE2B b7d796744cb4c7b944e98644dfb9c0e44ba465a6dba71b9e891604f3012b025557dbcd5b7eeae02e71c84350e05b334f99404ddfda814a8984b7a893d3f092f7 SHA512 37a84d7c57da7a3e48870abf992ba96ee454b342610d51c06f7dfc7ee082b7fb51304518c208379c3dbd039eafb1a85444c257fed20b4605a52dc8fc938a4cca
DIST websockets-11.0.gh.tar.gz 347307 BLAKE2B b40b8e88375a1e5e0f6ae1c73169703d206800dcec15d858a0360374701b681ec17c457b014a29dc34962ca1f62261a8b8298e34092429864d790dd4a060e8d8 SHA512 367347464d5d721ad65055743df92311e7d98d0391ff437ab8c3224f1c1e4193b5abbdbf1498cd040d9b30251e6bc051e9c1ec54122b87e4c937026e0f6f3b8e
diff --git a/dev-python/websockets/websockets-11.0.3.ebuild b/dev-python/websockets/websockets-11.0.3.ebuild
new file mode 100644
index 000000000000..f3ef9af590b3
--- /dev/null
+++ b/dev-python/websockets/websockets-11.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/python-websockets/websockets/
+ https://pypi.org/project/websockets/
+"
+# tests are missing pypi sdist, as of 11.0
+SRC_URI="
+ https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export BUILD_EXTENSION=$(usex native-extensions)
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+
+ epytest tests
+}