summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wehjit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wehjit')
-rw-r--r--dev-python/wehjit/Manifest1
-rw-r--r--dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch23
-rw-r--r--dev-python/wehjit/metadata.xml18
-rw-r--r--dev-python/wehjit/wehjit-0.2.2-r1.ebuild37
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/wehjit/Manifest b/dev-python/wehjit/Manifest
new file mode 100644
index 000000000000..f2e26987233a
--- /dev/null
+++ b/dev-python/wehjit/Manifest
@@ -0,0 +1 @@
+DIST wehjit-0.2.2.tar.gz 100515 SHA256 71e16919ff816bc06492647a7e3eda9619bb04ba8fb729f97106131126e9d1fb SHA512 f8fb2edeeb9e90315d3c8f1e9e7d73d556fcad780c4dea637599291b2094e292a42b6f3671407f3d9d88733894501796484fa05ac52f3c1f3e1cb29d376a87fb WHIRLPOOL a1909009f0445de5d7c323ee05ab39a76f127ab89d3c9a96205f125b88277e3068ea3e2b3548cbadb69ddab7c5cc17dd87d8895c948bdd4adc00cf06bd949009
diff --git a/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
new file mode 100644
index 000000000000..057d70747e74
--- /dev/null
+++ b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
@@ -0,0 +1,23 @@
+diff -ur wehjit-0.2.2.orig/wehjit/collection.py wehjit-0.2.2/wehjit/collection.py
+--- wehjit/collection.py 2010-02-11 16:26:14.000000000 +0800
++++ wehjit/collection.py 2012-11-08 14:24:40.326482713 +0800
+@@ -22,6 +22,11 @@
+ Collect widget plugins together in a `Collection`.
+ """
+
++import sys
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
+ import inspect
+ import os
+ from os import path
+@@ -130,6 +135,7 @@
+ """
+ return name in self.__plugins
+
++ @unittest.skip("Plugin not in gentoo")
+ def __getitem__(self, name):
+ """
+ Return the plugin named ``name``.
diff --git a/dev-python/wehjit/metadata.xml b/dev-python/wehjit/metadata.xml
new file mode 100644
index 000000000000..a0dee8239a94
--- /dev/null
+++ b/dev-python/wehjit/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<herd>python</herd>
+<maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+<longdescription>
+ wehjit is a Python library for for building XHTML widgets for web
+ applications and web pages. It encapsulates the XHTML
+ (a Genshi XML template), CSS, and JavaScript for each widget into a plugin
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/wehjit/wehjit-0.2.2-r1.ebuild b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..41f5f303bcb5
--- /dev/null
+++ b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python web-widget library"
+HOMEPAGE="http://jderose.fedorapeople.org/wehjit"
+SRC_URI="http://jderose.fedorapeople.org/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/genshi
+ dev-python/assets[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( README NEWS )
+
+PATCHES=( "${FILESDIR}"/${P}-SkipTest.patch )
+
+python_test() {
+ if [[ "${EPYTHON:6:3}" == '2.6' ]]; then
+ nosetests -I test_app* -e=*getitem
+ else
+ nosetests
+ fi
+}