summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 13:56:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 14:02:59 +0200
commitca48c7ead7593d7e6be290c3c723bd23fb3f16bc (patch)
treeeecdc53898efdda213496d668aad3bb6f3b40675 /dev-python/wheel
parentdev-python/wheel: Stabilize 0.34.2 ALLARCHES (diff)
downloadgentoo-ca48c7ead7593d7e6be290c3c723bd23fb3f16bc.tar.gz
gentoo-ca48c7ead7593d7e6be290c3c723bd23fb3f16bc.tar.bz2
gentoo-ca48c7ead7593d7e6be290c3c723bd23fb3f16bc.zip
dev-python/wheel: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest2
-rw-r--r--dev-python/wheel/wheel-0.29.0.ebuild45
-rw-r--r--dev-python/wheel/wheel-0.33.6.ebuild28
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index cfffb36ffbae..230d4688975d 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,3 +1 @@
-DIST wheel-0.29.0.tar.gz 54143 BLAKE2B 8f29c81b9b3c8ee419c26f04e09f437a2113716f5096e1b6e21f23e6a7426e58b7ee00c0846cfcd816670bee4dd908ef577e4142fae546d4ea643af2c2612049 SHA512 b72dec3cf71e3d87c611ff41f1381ed7f2c654edb50c808fb4fd0f552bab3572434495bf18c36d2ecc7cb8b355782054d3d6dedd5589ffda15027e72cff24602
-DIST wheel-0.33.6.gh.tar.gz 50273 BLAKE2B bc315c87b83bed39ad4ec08dde31edd570e59b65ff28c64c89b1b5e1f2e526fd6035dbe9902dd9a3efd94b0c5584489f28ed895b36e4eb9dd1ddc225d7069275 SHA512 04edf619ee6fd06f1e4c8bc513c6e21ba91615eba42bca5473e60573e274133b1019774b8e3a960e05f5a69bb256508d0a8a31fd9ab91a28f1b87d1095b17b5e
DIST wheel-0.34.2.gh.tar.gz 57175 BLAKE2B 4d06c411561f80e51c15422f2d3318efa565f9119e869a2f9284adb9bd3aff7bc104013a63fefae36742d7d87c8468b42292723ed031c2b109323a9141fd1cea SHA512 fcd02cf770382c26b5250aa48f60481ac868ff7e1b08245ed4616aaa7d6dc5e3280d9ab787c4d1690b11550de9f6160c0d31dd65b79554711ab5d02de479e1ab
diff --git a/dev-python/wheel/wheel-0.29.0.ebuild b/dev-python/wheel/wheel-0.29.0.ebuild
deleted file mode 100644
index 3b889e9e330f..000000000000
--- a/dev-python/wheel/wheel-0.29.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-# test? (
-# dev-python/keyring
-# dev-python/keyrings_alt
-# dev-python/ed25519ll
-# dev-python/pytest[${PYTHON_USEDEP}]
-# )
-#"
-
-# Fails somehow
-RESTRICT=test
-
-python_test() {
- sed \
- -e 's:--cov=wheel::g' \
- -i setup.cfg || die
- py.test -v -v || die "testsuite failed under ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "Signature support" \
- dev-python/keyring \
- dev-python/keyrings_alt \
- dev-python/ed25519ll
-}
diff --git a/dev-python/wheel/wheel-0.33.6.ebuild b/dev-python/wheel/wheel-0.33.6.ebuild
deleted file mode 100644
index dd2363cb0fee..000000000000
--- a/dev-python/wheel/wheel-0.33.6.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed \
- -e 's:--cov=wheel::g' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}