summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-08 13:43:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-09 13:35:16 +0200
commitebe08273ebbf71cdc25249ef735e8d2baf24e69c (patch)
tree0afa6f0bcfdefa30a289075e10ac8773e8cd6b0d /dev-python/whisper
parentdev-python/sniffio: Port to python3.10 (diff)
downloadgentoo-ebe08273ebbf71cdc25249ef735e8d2baf24e69c.tar.gz
gentoo-ebe08273ebbf71cdc25249ef735e8d2baf24e69c.tar.bz2
gentoo-ebe08273ebbf71cdc25249ef735e8d2baf24e69c.zip
dev-python/whisper: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
index ad3271e64c22..0b3dd86386f4 100644
--- a/dev-python/whisper/whisper-1.1.7.ebuild
+++ b/dev-python/whisper/whisper-1.1.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Fixed size round-robin style database"
@@ -15,19 +15,7 @@ SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
distutils_enable_tests pytest
-
-#python_test() {
-# py.test || die "tests failed with ${EPYTHON}"
-#}