summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 16:15:10 +0000
committerSam James <sam@gentoo.org>2021-01-17 16:16:03 +0000
commitf7dcabba6af6dbc3729ce0ec69cf31ece6f255f7 (patch)
tree2f24a4e472ef1a46487bd63490ad9aa520c7f81f /dev-python/whisper
parentdev-python/path-py: bump to 15.0.1 (diff)
downloadgentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.tar.gz
gentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.tar.bz2
gentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.zip
dev-python/whisper: bump to 1.1.7
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest1
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index d6c316848ac3..4ecf372e5722 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1 +1,2 @@
DIST whisper-1.1.5.tar.gz 38104 BLAKE2B ab36c91c00dd8e8e26b24c0c2967c661f0bd69f3dcb0e52763f6527a233f656a984c738be720c0b5f2d27fff08daa164db87f0ab693d360bd0c087cf6a408340 SHA512 dee42adf1824c876cf15e9e55101d90d08889fd6e267a89c18fdb4a7d4c5a3a0d4f6f24bb0fdeb974fd194046c17e00f71033ddb72c74c4d4ded0a937e82c8a9
+DIST whisper-1.1.7.tar.gz 38289 BLAKE2B 05c5ed972c6dbe8ecc29731d206a44e4db2605aa1270d0eba63c90390062f3cee81a6076a571e6b18cc54f8b1a0ffbc9800c91e9aa7cf3cab862d7e6bb8217c0 SHA512 2dc4f15a91b518495da120af4ad2af4b5f81d04fae6028ca1d7505046b93082a9294452a703c8de87dc89629c35dca0809c4ee7c0df1a7a6bd5ec527f3126df2
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
new file mode 100644
index 000000000000..201d0c86240a
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+#python_test() {
+# py.test || die "tests failed with ${EPYTHON}"
+#}