summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-05 19:31:09 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-05 19:33:12 -0400
commit23cd720e59bc7ae08927889f6d72dfc7714d16f3 (patch)
tree0c477b828cf7979ede75c9afafe92f16c7897f48 /dev-python/whoosh
parentapp-emulation/ganeti: Clean out 2.15.2-r3 (diff)
downloadgentoo-23cd720e59bc7ae08927889f6d72dfc7714d16f3.tar.gz
gentoo-23cd720e59bc7ae08927889f6d72dfc7714d16f3.tar.bz2
gentoo-23cd720e59bc7ae08927889f6d72dfc7714d16f3.zip
dev-python/whoosh: version bump to 2.7.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/Manifest1
-rw-r--r--dev-python/whoosh/whoosh-2.7.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/whoosh/Manifest b/dev-python/whoosh/Manifest
index 00deffa7565d..62aa10a8731f 100644
--- a/dev-python/whoosh/Manifest
+++ b/dev-python/whoosh/Manifest
@@ -2,3 +2,4 @@ DIST Whoosh-2.6.0.zip 1193541 SHA256 7de7bc4d00a6d051dbb360b48eb7f3cd002373d8725
DIST Whoosh-2.7.0.zip 1080985 SHA256 733df1ad4142fcd1e8f3259070de0521d272d7685e2febc0f4fdd1668cfe0d48 SHA512 5126a9ed5ef50af391905347c7aa1c1cc7d100213c29f5a5f67fcfabab9cdcfcd14a6b75735df8e343f61254d1fec8610f0e1260167a321ab303a0a55b02673f WHIRLPOOL 6a35448280e3c6382b8a4b50432d5def3a910d9af95d35afc11544030b69f0103aae910bbf91cb5942ec80f10a848bbd32dbd828c71482f5e2fc15a9cd29c249
DIST Whoosh-2.7.2.zip 1096847 SHA256 0f72a49e02e2669a50f1ecaf0364fe0451619473c404efeca9914dd878de73f2 SHA512 3a5e41328e9bce102b9e68d648f6a0e61fa7e6be1585fd70a5885afb885717d0a4e73ef1b6d2086edec996228bbfbd6d7e01eaa64e831223ef1ea7b764d25d7f WHIRLPOOL eaaa85fd62e03bb63ac8cc48c9e29b2c9daf435e848aec7b7747e6fd390245bda044c5e9bafbf9e5f7df22b93e4cfacdc180cc821e3bd4739c229f6aaf9b58e0
DIST Whoosh-2.7.3.zip 1097515 SHA256 aa6db447522e208ae652c6ce063bb23cedec47f5ed630121b3debaa011fcb9c4 SHA512 3df18ed30f63aaa9f858d596919fa8a927f7203a52bdb4c584117b28bce313cbbb530cdb144e35af99763edbbc7d3f5c79680d04fa7c04efa91376ba62b6f556 WHIRLPOOL 1829fd083485367dd0751844c77e5f7e8c8edee4021b8518415ab6cd6f8db84b5f2f188d6e2128a105cfd8076d8101c1421838ac18f10cd632c64eed5828a44e
+DIST Whoosh-2.7.4.zip 1097662 SHA256 e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69 SHA512 8ea2f10152b0eb9fbf516a3faeed5a466216eb468f0e4b88d156591d5a36c5dc7d3408928bbd693de98bb0351b9c33cc62900c13ea56d3b3d989c1a4bbeba139 WHIRLPOOL 56622fc1049c2bfefdb4ec49e4784e7d751837cdd0cc379e7eb737da34a2dc0c6d3e7e85696ba0be60c3dd55f1981b6473391555d3851c82b7e816bab20db5d8
diff --git a/dev-python/whoosh/whoosh-2.7.4.ebuild b/dev-python/whoosh/whoosh-2.7.4.ebuild
new file mode 100644
index 000000000000..dcff87783027
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.7.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+MY_PN="Whoosh"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.python.org/pypi/Whoosh/"
+SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://bitbucket.org/mchaput/whoosh/issue/403/
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
+}
+
+python_test() {
+ # https://bitbucket.org/mchaput/whoosh/issue/412/tarball-of-whoosh-270-pypi-missing-english
+ # tarball missing a file english-words.10.gz which when added sees all tests pass.
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( README.txt )
+ use doc && local HTML_DOCS=( docs/source/build/html/. )
+ distutils-r1_python_install_all
+}