summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 19:57:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:08 -0500
commit9357af144561302d90c3bcf6fedd8f565377ad2f (patch)
tree339fefda7f156f02bac2b5fd9675ffa3d780baf6 /dev-python/wrapt/wrapt-1.10.10.ebuild
parentdev-python/stevedore: 1.25.0 bup (diff)
downloadgentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.tar.gz
gentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.tar.bz2
gentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.zip
dev-python/wrapt: 1.10.10 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/wrapt/wrapt-1.10.10.ebuild')
-rw-r--r--dev-python/wrapt/wrapt-1.10.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.10.10.ebuild b/dev-python/wrapt/wrapt-1.10.10.ebuild
new file mode 100644
index 000000000000..5ff5ec966398
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.10.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test -vv || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}