summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ws4py
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/Manifest1
-rw-r--r--dev-python/ws4py/files/ws4py-0.2-cherrypy_test.patch24
-rw-r--r--dev-python/ws4py/files/ws4py-0.2.1-process-data.patch27
-rw-r--r--dev-python/ws4py/metadata.xml16
-rw-r--r--dev-python/ws4py/ws4py-0.3.4.ebuild52
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild52
6 files changed, 172 insertions, 0 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
new file mode 100644
index 000000000000..faabfe0a735a
--- /dev/null
+++ b/dev-python/ws4py/Manifest
@@ -0,0 +1 @@
+DIST ws4py-0.3.4.tar.gz 65467 SHA256 5aedb5663ee1e5fb4334615cc6582f4f2e97cf967d8dc4c6c3627515d16afa90 SHA512 32cd2eb9df7367e2bf42e354766a0ca407715a863be6b51b7701ec6e0537a2ecf7c2a59423f56ae093855b075c30a4065c7f7efe3b0227915639223b9ba7a55f WHIRLPOOL 77f6c56ab1c2bbcd628f0d1773c1c9659ddc68d976ca8af55804d04e16ec6e9e06e87f5a6a3167670d8c0898dde657f3b3b1fdc4d4a94029f74d71ca2ee50e1b
diff --git a/dev-python/ws4py/files/ws4py-0.2-cherrypy_test.patch b/dev-python/ws4py/files/ws4py-0.2-cherrypy_test.patch
new file mode 100644
index 000000000000..e1d55afa0a6b
--- /dev/null
+++ b/dev-python/ws4py/files/ws4py-0.2-cherrypy_test.patch
@@ -0,0 +1,24 @@
+db23aff2ea commit 4ec8638c268ecdb710d97176a55cc5b818aa1a18
+https://github.com/Lawouach/WebSocket-for-Python/issues/72
+diff -ur ws4py-0.2.4.orig/test/test_cherrypy.py ws4py-0.2.4/test/test_cherrypy.py
+--- test/test_cherrypy.py 2012-12-14 03:35:48.000000000 +0800
++++ test/test_cherrypy.py 2013-01-11 16:56:37.555534011 +0800
+@@ -4,6 +4,7 @@
+ import cherrypy
+ from ws4py.server.cherrypyserver import WebSocketPlugin, WebSocketTool
+ from ws4py.websocket import EchoWebSocket
++from ws4py.compat import py3k
+
+ class FakeSocket(object):
+ def settimeout(self, timeout):
+@@ -65,7 +66,10 @@
+ h = EchoWebSocket(s, [], [])
+ cherrypy.engine.publish('handle-websocket', h, ('127.0.0.1', 0))
+ self.assertEquals(len(cherrypy.engine.websocket.pool), 1)
+- k = cherrypy.engine.websocket.pool.keys()[0]
++ if py3k:
++ k = list(cherrypy.engine.websocket.pool.keys())[0]
++ else:
++ k = cherrypy.engine.websocket.pool.keys()[0]
+ self.assertTrue(k is h)
+ self.assertEquals(cherrypy.engine.websocket.pool[k][1], ('127.0.0.1', 0))
diff --git a/dev-python/ws4py/files/ws4py-0.2.1-process-data.patch b/dev-python/ws4py/files/ws4py-0.2.1-process-data.patch
new file mode 100644
index 000000000000..5476f2d28625
--- /dev/null
+++ b/dev-python/ws4py/files/ws4py-0.2.1-process-data.patch
@@ -0,0 +1,27 @@
+From 38cf669e27fab9de187eb11dabd7d85d73d5f470 Mon Sep 17 00:00:00 2001
+From: Jon Salz <jsalz@chromium.org>
+Date: Fri, 20 Apr 2012 02:22:46 +0800
+Subject: [PATCH] Process remaining bytes in the body, if any.
+
+https://github.com/Lawouach/WebSocket-for-Python/issues/46
+---
+ ws4py/client/__init__.py | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/ws4py/client/__init__.py b/ws4py/client/__init__.py
+index aa4c8f2..29b1357 100644
+--- a/ws4py/client/__init__.py
++++ b/ws4py/client/__init__.py
+@@ -71,6 +71,9 @@ class WebSocketBaseClient(WebSocket):
+
+ self.handshake_ok()
+
++ if body != '':
++ self.process(body)
++
+ @property
+ def handshake_headers(self):
+ parts = urlsplit(self.url)
+--
+1.7.3.4
+
diff --git a/dev-python/ws4py/metadata.xml b/dev-python/ws4py/metadata.xml
new file mode 100644
index 000000000000..6a2af9d51e73
--- /dev/null
+++ b/dev-python/ws4py/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ <description>make whatever changes you want</description>
+ </maintainer>
+ <use>
+ <flag name="client">Install client modules</flag>
+ <flag name="server">Install server modules</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Lawouach/WebSocket-for-Python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ws4py/ws4py-0.3.4.ebuild b/dev-python/ws4py/ws4py-0.3.4.ebuild
new file mode 100644
index 000000000000..fabf578d972c
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ... so why not???
+# pypy is viable but better with a cutdown set of deps
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm x86"
+fi
+
+DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+# doc build requires sphinxcontrib ext packages absent from portage
+
+RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
+ server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # testsuite displays an issue with mock under py3 but is non fatal
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
+}
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
new file mode 100644
index 000000000000..7b17719d187d
--- /dev/null
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ... so why not???
+# pypy is viable but better with a cutdown set of deps
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+# doc build requires sphinxcontrib ext packages absent from portage
+
+RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
+ server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # testsuite displays an issue with mock under py3 but is non fatal
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
+}