summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 04:27:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 04:40:54 +0200
commitdbe9bad340a174a12e5c44f4e6d90e47b713ab0e (patch)
treef7c682e550f05c986eed485a778d05171b63cd76 /dev-python/wsaccel
parentdev-python/mkdocstrings-python: Bump to 1.6.2 (diff)
downloadgentoo-dbe9bad340a174a12e5c44f4e6d90e47b713ab0e.tar.gz
gentoo-dbe9bad340a174a12e5c44f4e6d90e47b713ab0e.tar.bz2
gentoo-dbe9bad340a174a12e5c44f4e6d90e47b713ab0e.zip
dev-python/wsaccel: Bump to 0.6.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsaccel')
-rw-r--r--dev-python/wsaccel/Manifest1
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wsaccel/Manifest b/dev-python/wsaccel/Manifest
index b32d3f32d143..25244e3912f9 100644
--- a/dev-python/wsaccel/Manifest
+++ b/dev-python/wsaccel/Manifest
@@ -1 +1,2 @@
DIST wsaccel-0.6.4.gh.tar.gz 9947 BLAKE2B 1c0b7b8b82154420f64fcbf3217938ff7e829573ada6b979ff73fe450c0985e368a47cccf2d124506c28479a98f0799977677e16ee26754611362f6b61eff902 SHA512 980364fab8a661c8a2b406f9eb6c99fb5f3a1308bbcf6267fa63f002d8dfbb4a3ad027d83a2088d69324cab05bdc56138d7e66e2602aeb8864dfe49ad9218d07
+DIST wsaccel-0.6.6.gh.tar.gz 9930 BLAKE2B f8d8c9ae0966374fbd965859150cca68b3fae6f39fdcfa744f98e7fade2a76946b57bea753c2dbb4051ef635e0dd0fbfd915c7f8bf4b9b5cd2b5b372694d632f SHA512 4a107db921f6f6549fb9f2f0b5c698331274171ef509136fc2d83cb6ca8bedbde32a14aaca4e38e16af3054337774dbd6aa7d8caee7866a51ded751d7d3764be
diff --git a/dev-python/wsaccel/wsaccel-0.6.6.ebuild b/dev-python/wsaccel/wsaccel-0.6.6.ebuild
new file mode 100644
index 000000000000..74b7274a1965
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="
+ https://github.com/methane/wsaccel/
+ https://pypi.org/project/wsaccel/
+"
+SRC_URI="
+ https://github.com/methane/wsaccel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest
+}