summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-04-20 12:51:32 -0400
committerRick Farina <zerochaos@gentoo.org>2020-04-20 13:31:13 -0400
commit33f1aae3b5b0bbde2a71c4602360407f547c0f49 (patch)
tree87ac8683b4ab59ec22b817e432ad6bf41c1a9173 /dev-python/wsproto/wsproto-0.15.0.ebuild
parentdev-python/configclass: 0.2.0 (diff)
downloadgentoo-33f1aae3b5b0bbde2a71c4602360407f547c0f49.tar.gz
gentoo-33f1aae3b5b0bbde2a71c4602360407f547c0f49.tar.bz2
gentoo-33f1aae3b5b0bbde2a71c4602360407f547c0f49.zip
dev-python/wsproto: simple bump
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/wsproto/wsproto-0.15.0.ebuild')
-rw-r--r--dev-python/wsproto/wsproto-0.15.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wsproto/wsproto-0.15.0.ebuild b/dev-python/wsproto/wsproto-0.15.0.ebuild
new file mode 100644
index 000000000000..e6b15a59a3ea
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-python/h11-0.8*[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Testing failed"
+}