summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-27 10:27:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-27 10:33:00 +0200
commit8296d84f636d997e97557502af45ff39647d7d9c (patch)
tree521885610ef1aa2f432b0904d5e36c75e8ff7fc1 /dev-python/wsproto/wsproto-0.15.0.ebuild
parentdev-python/dataclasses: New package (diff)
downloadgentoo-8296d84f636d997e97557502af45ff39647d7d9c.tar.gz
gentoo-8296d84f636d997e97557502af45ff39647d7d9c.tar.bz2
gentoo-8296d84f636d997e97557502af45ff39647d7d9c.zip
dev-python/wsproto: Bump to 0.15.0
Closes: https://bugs.gentoo.org/696670 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto/wsproto-0.15.0.ebuild')
-rw-r--r--dev-python/wsproto/wsproto-0.15.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/wsproto/wsproto-0.15.0.ebuild b/dev-python/wsproto/wsproto-0.15.0.ebuild
new file mode 100644
index 000000000000..b4e0f094aaf7
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.15.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dataclasses[${PYTHON_USEDEP}]
+ ' python3_6)
+"
+
+distutils_enable_tests pytest