summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:39:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:37 +0100
commit3eefb413dced182db20c17de86a7a705911ba7e9 (patch)
tree8ffaef27367cfb3c598de193f1cd740e9bfd2770 /dev-python/wsproto
parentdev-python/nuitka: Bump to 0.7.2 (diff)
downloadgentoo-3eefb413dced182db20c17de86a7a705911ba7e9.tar.gz
gentoo-3eefb413dced182db20c17de86a7a705911ba7e9.tar.bz2
gentoo-3eefb413dced182db20c17de86a7a705911ba7e9.zip
dev-python/wsproto: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest1
-rw-r--r--dev-python/wsproto/wsproto-1.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index f31f595c1112..dacaf902aea9 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1 +1,2 @@
DIST wsproto-1.0.0.tar.gz 53423 BLAKE2B b4cc8c1ef0ccf324821b893b57fc86ab744c639dd07604618485004ef56ca105b5515e1f34a08ccc93de941b1a93eb76ef0d1946f11e05f80d40b98bfe7e4c56 SHA512 36f8c4eebf84bfe869f7124330898d22416b423f47396f2e3f72069e14f1763514e1df700c3e8ee81467cf973197e10143e088978d0688930fa98518af8773fb
+DIST wsproto-1.1.0.tar.gz 52928 BLAKE2B 837f5d8411a55b026d8c5df8b03b44c92f71fe2856884e5199e639a5c060fabbe8eec39cb6861e8f88ae7fc366cbeef4f9d62dade2c95857d27339fa73e90638 SHA512 0cd726bc62ca4d11e96f470f51511008bd43dbb9e99a17633d2a40da7bdaf19716e0a1c995350f5c8f418f906848dd6f2b9b0a853c1b6858ddafa1cc02fab710
diff --git a/dev-python/wsproto/wsproto-1.1.0.ebuild b/dev-python/wsproto/wsproto-1.1.0.ebuild
new file mode 100644
index 000000000000..b28abfcd3c2d
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="
+ https://github.com/python-hyper/wsproto/
+ https://pypi.org/project/wsproto/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/h11-0.9[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest