summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:32:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:50 +0100
commit7f0359d17606b6c009b667486b6bd5e236518c3b (patch)
tree9b8c05b3c5e742a9eaf3fc0d16c64f8c33982822 /dev-python/wsproto
parentdev-python/validators: EAPI 8, PEP517 (diff)
downloadgentoo-7f0359d17606b6c009b667486b6bd5e236518c3b.tar.gz
gentoo-7f0359d17606b6c009b667486b6bd5e236518c3b.tar.bz2
gentoo-7f0359d17606b6c009b667486b6bd5e236518c3b.zip
dev-python/wsproto: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/wsproto-1.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wsproto/wsproto-1.0.0-r1.ebuild b/dev-python/wsproto/wsproto-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..b28abfcd3c2d
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="
+ https://github.com/python-hyper/wsproto/
+ https://pypi.org/project/wsproto/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/h11-0.9[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest