summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wtforms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/Manifest3
-rw-r--r--dev-python/wtforms/metadata.xml8
-rw-r--r--dev-python/wtforms/wtforms-1.0.4.ebuild42
-rw-r--r--dev-python/wtforms/wtforms-2.0.1.ebuild40
-rw-r--r--dev-python/wtforms/wtforms-2.0.2.ebuild40
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
new file mode 100644
index 000000000000..c99e93c4df45
--- /dev/null
+++ b/dev-python/wtforms/Manifest
@@ -0,0 +1,3 @@
+DIST WTForms-1.0.4.zip 345261 SHA256 15e1c114cd32c8be2d08585f5b158c941e2193d19b0a16194d1fde53e4291eef SHA512 0f0bda1e225a1132784814d6129039ba964aeef8d2ca8509e6d9be9ecf83fbf76f6a71f18fbb43772dbe64802e9a2038c53e2098ec25ec8cd2ebb223206ab880 WHIRLPOOL edf9ad35c44d149fa08e2c47a5a69662545fa22743c004ec36d76593c73ecfb7975bd93ae92018c0e4fa425edf0c7f1cea30f4f452331b3e09c0722e5fa6a91a
+DIST WTForms-2.0.1.zip 444489 SHA256 62859c74be4683601b5265ba83b9babd8a8f1cdd0ba31600fa1e70d295cd4ed2 SHA512 abae7adb1c7ab46abf401a536a248bf3703be2f0be9f5d8d49191f18855a6989e4c7acb232b006d5809fc13428a9e6214f734be5b917648778169c7dd258eaab WHIRLPOOL d6177e7f9ff5e53085081fb4580d728c08ac19230470435a85a0735745f303b010540ce01e4071735a49f32bb3321d17557511f958452457a882705c3139da9b
+DIST WTForms-2.0.2.zip 449167 SHA256 10737758ceae03b53021f3aa7e81bfc8dd6f679c879ffeb5e64ac6570facb6c1 SHA512 35d52b2991588d1aef2ed7df5713f5cdd7d64affb0879ccf6b40b9194c3b9492af8f853353df55f833bec268d4332d49cf4c8e0592c21a11cccddaddb3650c52 WHIRLPOOL 7664b533174b44922e8ce733b6d284a1c8814190bab631cf094e0e7f841152502329f203e34638bb6aea2386b74a1afa7e5de09ada06188a39989f4f860e875e
diff --git a/dev-python/wtforms/metadata.xml b/dev-python/wtforms/metadata.xml
new file mode 100644
index 000000000000..e93485a616ed
--- /dev/null
+++ b/dev-python/wtforms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">WTForms</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wtforms/wtforms-1.0.4.ebuild b/dev-python/wtforms/wtforms-1.0.4.ebuild
new file mode 100644
index 000000000000..e48bf7dbde14
--- /dev/null
+++ b/dev-python/wtforms/wtforms-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}
diff --git a/dev-python/wtforms/wtforms-2.0.1.ebuild b/dev-python/wtforms/wtforms-2.0.1.ebuild
new file mode 100644
index 000000000000..34afac6dc1f9
--- /dev/null
+++ b/dev-python/wtforms/wtforms-2.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test || die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/wtforms/wtforms-2.0.2.ebuild b/dev-python/wtforms/wtforms-2.0.2.ebuild
new file mode 100644
index 000000000000..3f0da0256c1f
--- /dev/null
+++ b/dev-python/wtforms/wtforms-2.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test || die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}