summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-11 15:54:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-11 16:01:54 +0100
commitdddb1cc00a218d64acebce64832df1d4dbdaa009 (patch)
treea1c1261a1838e74d762a4c49a3de3342166e972f /dev-python/xarray
parentdev-python/sphinx-gallery: enable python3.10 (diff)
downloadgentoo-dddb1cc00a218d64acebce64832df1d4dbdaa009.tar.gz
gentoo-dddb1cc00a218d64acebce64832df1d4dbdaa009.tar.bz2
gentoo-dddb1cc00a218d64acebce64832df1d4dbdaa009.zip
dev-python/xarray: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-0.19.0.ebuild46
-rw-r--r--dev-python/xarray/xarray-0.20.1.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 07fc99dd7e3c..01978936404f 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,3 +1 @@
-DIST xarray-0.19.0.tar.gz 2882403 BLAKE2B 454595076074c9805f0ff6f8b761a61e4c172445f2fd0bbcbd39a9615f3465704871fbc5f7c1a9c5fbb1c80b6c47cd677e590e1513ca88cd67908ef3502d234e SHA512 8f4ce7f770ea10e757112b722c7e7a56f19be2f885c63620d547cc54d8b625a5a23c5e603ba804c4d94f2a94863aad8351a9f6ef22ccbc1a78d77a549a21356e
-DIST xarray-0.20.1.tar.gz 2896122 BLAKE2B 75dbebab105fb2b0c78d09e6dba30bf90a87d1e0b97b96cacc7f880a34734811dae7ebd6b4858718d70f7e03d99c8d58de9b6091d354831ccd17c3946b44e9b6 SHA512 d2e6162286c7e7debed27f40082086dbb55467a953a2afa81b08313aa111c28ffa942785687ac57cb60241a1f45a5d9a937a10bcc7c3025860f7251bbac79c22
DIST xarray-0.20.2.tar.gz 2906021 BLAKE2B 08ed46a27ce66ec1677e63000d74ecc4a01defa81b8ae1ec24595ff330713bf3e5585adce541e5e6769a74d64a4f5eb9d9aad27450e8088973681d0d60d00f83 SHA512 cd292af68ffd8016e01021e30a2ea83dd36e2f79bd9c3d8e7d83adc5a98a95615091d0102a19a0e3337ae334a701f575a142f476d1465804c8d5fe259ca35f1a
diff --git a/dev-python/xarray/xarray-0.19.0.ebuild b/dev-python/xarray/xarray-0.19.0.ebuild
deleted file mode 100644
index 0315b612b3d6..000000000000
--- a/dev-python/xarray/xarray-0.19.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# pkg_resources use in code
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="https://xarray.pydata.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
-# note: most of test dependencies are optional
-BDEPEND="
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/xarray/xarray-0.20.1.ebuild b/dev-python/xarray/xarray-0.20.1.ebuild
deleted file mode 100644
index a4410243510a..000000000000
--- a/dev-python/xarray/xarray-0.20.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# pkg_resources use in code
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="https://xarray.pydata.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.1[${PYTHON_USEDEP}]"
-# note: most of test dependencies are optional
-BDEPEND="
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
- )
-
- epytest ${deselect[@]/#/--deselect }
-}