summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 18:09:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 18:24:32 +0200
commitb3cf50ce256a24b1dc709230d650618f0c9b83c7 (patch)
treecf56a7ff0933ba15c475f776e4e5aac9f7ae2af5 /dev-python/xcffib
parentdev-python/requests: keyworded 2.23.0 for hppa, bug #700940 (diff)
downloadgentoo-b3cf50ce256a24b1dc709230d650618f0c9b83c7.tar.gz
gentoo-b3cf50ce256a24b1dc709230d650618f0c9b83c7.tar.bz2
gentoo-b3cf50ce256a24b1dc709230d650618f0c9b83c7.zip
dev-python/xcffib: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/xcffib-0.9.0.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/xcffib/xcffib-0.9.0.ebuild b/dev-python/xcffib/xcffib-0.9.0.ebuild
index 014ddb3a75d3..733fcfb15064 100644
--- a/dev-python/xcffib/xcffib-0.9.0.ebuild
+++ b/dev-python/xcffib/xcffib-0.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit distutils-r1 virtualx
@@ -14,24 +14,23 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
DEPEND="x11-libs/libxcb"
RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
dev-python/six[${PYTHON_USEDEP}]
${DEPEND}"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]
x11-apps/xeyes
)"
+distutils_enable_tests nose
+
PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
-python_test() {
- virtx nosetests -d -v
+src_test() {
+ virtx distutils-r1_src_test
}