summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-11-13 10:59:22 -0800
committerBrian Dolbec <dolsen@gentoo.org>2016-11-13 11:35:50 -0800
commit099ba4c8985a900edee70fcbc1a151142f92d02f (patch)
treee9fe23dbfaf7ab730668c1fb30bfc6c95baa35b9 /dev-python/xdis
parentdev-python/xdis: Fix setup.py unconditional test dep bug 596510 (diff)
downloadgentoo-099ba4c8985a900edee70fcbc1a151142f92d02f.tar.gz
gentoo-099ba4c8985a900edee70fcbc1a151142f92d02f.tar.bz2
gentoo-099ba4c8985a900edee70fcbc1a151142f92d02f.zip
dev-python/xdis: Version bump
Package-Manager: portage-2.3.2_p3
Diffstat (limited to 'dev-python/xdis')
-rw-r--r--dev-python/xdis/Manifest1
-rw-r--r--dev-python/xdis/xdis-3.2.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/xdis/Manifest b/dev-python/xdis/Manifest
index 26bdabfd9dcf..edb9caef275a 100644
--- a/dev-python/xdis/Manifest
+++ b/dev-python/xdis/Manifest
@@ -1 +1,2 @@
DIST xdis-2.3.1.tar.gz 69207 SHA256 9b28426a5b476b6740b83063604de7ef4af8b721a5da5894145fbae8921d25ae SHA512 5015914a13296d04e71050c2e916fd5770bfe8bba1f92bf3c64bca06365ea7547cbb216d7cfca19fdcef60af3943fa4ba4e7c27895b1da9c6240daf990051927 WHIRLPOOL c30ae717289c73069efbdb70cdd6388bb009e945c967de53b159aa2f8a606cdca8e28b265b4da56b7f77ab01b8a415b8d8d8b7e1b972370121ab86b18d8921e7
+DIST xdis-3.2.3.tar.gz 126710 SHA256 2e11b7dfafc02ce28da15f1d1bed327384ec34333d4a03e76cee8c1840897a5e SHA512 ce4e2ad09c1d13b2ab35b931ceedb8d08ec2f81dc2a34f50f854e6a4aca5efe857b56d6c2f1dbd73ae12d4ec9e2b0cc8e20c08873e87e4b0ca80fac229cebe06 WHIRLPOOL 1f553c3c57df5419b42ef6c94f7b78b5cbac14615d2d4066234420acd925b83df851332485a16ec8cace9ee5182b21b5bc1fc2fad7199ff4d6f17ce7de189cdb
diff --git a/dev-python/xdis/xdis-3.2.3.ebuild b/dev-python/xdis/xdis-3.2.3.ebuild
new file mode 100644
index 000000000000..fa8818dca320
--- /dev/null
+++ b/dev-python/xdis/xdis-3.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
+HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Fix an unconditional test only dep
+ sed \
+ -e "s/setup_requires/tests_require/" \
+ -i setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Need to rm any pyc files to prevent test failures.
+ rm -R "${S}"/test/__pycache__
+ PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
+ py.test -v || die "Tests failed under ${EPYTHON}"
+ cd test
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ ${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \
+ "Tests failed under ${EPYTHON}"
+}