summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-18 19:57:37 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-18 19:57:37 +0100
commit492a1f75e6c9589897d5f3ff589edf98bd452d96 (patch)
treedd8307a6fb8370e1c675287c3859984f2f36add0 /dev-python/xdoctest/xdoctest-0.15.0.ebuild
parentsci-libs/scikit-image: add python3_{8,9} (diff)
downloadgentoo-492a1f75e6c9589897d5f3ff589edf98bd452d96.tar.gz
gentoo-492a1f75e6c9589897d5f3ff589edf98bd452d96.tar.bz2
gentoo-492a1f75e6c9589897d5f3ff589edf98bd452d96.zip
dev-python/xdoctest: bump to 0.15.0, add py3_9, fix tests
Closes: https://bugs.gentoo.org/738486 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest/xdoctest-0.15.0.ebuild')
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/xdoctest/xdoctest-0.15.0.ebuild b/dev-python/xdoctest/xdoctest-0.15.0.ebuild
new file mode 100644
index 000000000000..28bec16bbff9
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.15.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # fails because the ebuild environment location is not the expected location
+ sed -i -e 's:test_xdoc_console_script_location:_&:' \
+ testing/test_entry_point.py || die
+
+ # xdoctest has to be in PATH for this to work
+ sed -i -e 's:test_xdoc_console_script_exec:_&:' \
+ testing/test_entry_point.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv || die "Test fail with ${EPYTHON}"
+}