summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-03-10 00:41:07 -0800
committerZac Medico <zmedico@gentoo.org>2017-03-10 01:14:30 -0800
commit3e0175950b11adf3cd5089e51b1fc228905153fb (patch)
treefae4f4c8024949a6b79c9dabe6279006ac2707cb /dev-python/xlwt/xlwt-1.2.0.ebuild
parentnet-p2p/qbittorrent: amd64 stable wrt bug #530720 (diff)
downloadgentoo-3e0175950b11adf3cd5089e51b1fc228905153fb.tar.gz
gentoo-3e0175950b11adf3cd5089e51b1fc228905153fb.tar.bz2
gentoo-3e0175950b11adf3cd5089e51b1fc228905153fb.zip
dev-python/xlwt: version bump to 1.2.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/xlwt/xlwt-1.2.0.ebuild')
-rw-r--r--dev-python/xlwt/xlwt-1.2.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/xlwt/xlwt-1.2.0.ebuild b/dev-python/xlwt/xlwt-1.2.0.ebuild
new file mode 100644
index 000000000000..f6c1c545352b
--- /dev/null
+++ b/dev-python/xlwt/xlwt-1.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
+HOMEPAGE="https://pypi.python.org/pypi/xlwt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Prevent d'loading in the doc build
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_prepare_all() {
+ # Don't install documentation and examples in site-packages directories.
+ sed -e "/package_data/d" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests || die "tests failed under ${EPYTHON}}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+ distutils-r1_python_install_all
+}