summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-10 14:16:06 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-10 14:40:29 +0100
commit54d4252291f393a6e5dca2bd92db1cf8ad1b2d2f (patch)
treed13a7b3021fd09877567bcb4b80608bff8569ac6 /dev-python/xmlschema/xmlschema-1.3.1.ebuild
parentsys-fs/quota: Removed old (diff)
downloadgentoo-54d4252291f393a6e5dca2bd92db1cf8ad1b2d2f.tar.gz
gentoo-54d4252291f393a6e5dca2bd92db1cf8ad1b2d2f.tar.bz2
gentoo-54d4252291f393a6e5dca2bd92db1cf8ad1b2d2f.zip
dev-python/xmlschema: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema/xmlschema-1.3.1.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-1.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xmlschema/xmlschema-1.3.1.ebuild b/dev-python/xmlschema/xmlschema-1.3.1.ebuild
new file mode 100644
index 000000000000..28637b92bf4f
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.0.2[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}