summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 23:05:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 23:21:12 +0100
commit6b8d4db8a6adac56bd6f4cc5c038ca5a39acc229 (patch)
treecde3054e08c55c94faa9e96c453d7774e1066a91 /dev-python/xmlschema
parentdev-python/setuptools: Bump to 54.0.0 (diff)
downloadgentoo-6b8d4db8a6adac56bd6f4cc5c038ca5a39acc229.tar.gz
gentoo-6b8d4db8a6adac56bd6f4cc5c038ca5a39acc229.tar.bz2
gentoo-6b8d4db8a6adac56bd6f4cc5c038ca5a39acc229.zip
dev-python/xmlschema: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 2b93416fe411..7a6e5f97205f 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-1.4.2.tar.gz 331747 BLAKE2B 013a74e7d929e46d497a55ad67888f0dd25b60097e390c3ad3b69c9a87d9e5a83bd68873336137805d755a47d0e5cb5b7347403ee38bcb7457e70803c6aca2ff SHA512 a490d1686f3e8cc7fd45bcb51f00ddf8b734e0c928f8690f9988232f8781fa070f7f03be7473ed5e8b3d1ab67bb08e123c79b408c3daaebfd2df0e94c8827888
DIST xmlschema-1.5.1.tar.gz 349788 BLAKE2B a46aa6619594de4db31158f26def3dc070629cc29112aa02555c2479f57883d7d5afb82cbc65e4193d607b2572049ff7da8cf3cb14850b0a6f3166ae87d86928 SHA512 5e8b3adbf8c5b4ac6a85a2d9b62212870cdc6639634f9adf9d16499d86b9cc73fd1fc6ba496f14d840ecefc60f175c62f077a62bab68bd057150889d5ae0a872
+DIST xmlschema-1.5.2.tar.gz 350754 BLAKE2B e00a25e12ebef613f4d89522e059fcbd41f28920da62bcf8782e6c345b44133072dd578ef547d51e547ed92e5424fc9a885f1c789544f83d5cfe1743fcbe2f30 SHA512 8ab6de10c40aa96f57c4dbb37af2256ec46b28a844f3ad7a44f6184ff38687581c7f038ef87374f49fb204f48053c4693a98fa79059e9074745e0d2a6f353bce
diff --git a/dev-python/xmlschema/xmlschema-1.5.2.ebuild b/dev-python/xmlschema/xmlschema-1.5.2.ebuild
new file mode 100644
index 000000000000..bb3a6af5bf3d
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.1.2[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}