summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-14 05:10:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-14 05:13:41 +0200
commitfd529f25ac21c197fbfde9f9fa2f1777ddd99fd1 (patch)
tree251fe1eff6aa1d4af1112fd13bb5ce3df2c7b0ef /dev-python/xmlschema
parentdev-python/pyrsistent: Bump to 0.17.3 (diff)
downloadgentoo-fd529f25ac21c197fbfde9f9fa2f1777ddd99fd1.tar.gz
gentoo-fd529f25ac21c197fbfde9f9fa2f1777ddd99fd1.tar.bz2
gentoo-fd529f25ac21c197fbfde9f9fa2f1777ddd99fd1.zip
dev-python/xmlschema: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.2.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 8ba0830523b4..026758327dfb 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-1.2.2.tar.gz 318829 BLAKE2B 5ebb8749d56491e65a2c09b56e965ea6b3e9be3d453a01671fa0da065389ca4bf44993693517bed4ef9df22cb94b9398660a7a838405c1757ee1c6f40aedacd3 SHA512 51be4317530cd1055438a4bf8e484b70d8a9414da5507fd30ed506271317859e5255fc729ed9fa5df2230e2af049ff40e693c67a5062e61fda43a1329ef2138d
DIST xmlschema-1.2.3.tar.gz 322076 BLAKE2B 2b6c587772a14b4b804a35614a2e1e77ade9be0ef25cabfc331efc3a443058fd51c178339f1d6df2cbda77d2a8d1c2ac2c33155406e7e7f36c10225ecb70a3e7 SHA512 15c47c7e93cb0bf14534dfc298848ba4ac332677583ee14eca0c5908fd935e1a3dc01b96f92e7df6eb45b215eae2b67d74ee2d4d227fb3e3360be944815532b7
+DIST xmlschema-1.2.4.tar.gz 287636 BLAKE2B bbb06fcf0e93b98ad7b9746fa0492bc79705dab79fa3d738bc02368e5d777b61cce60f6bd65f095dc99395037d7f0af3056c0877f0c96efb830fa65e1a389c2b SHA512 27f50890728be149e3c36a5ad706b27c32efecf859699a99bebe9a0b81dea2c1ab733860366a2cf0d30680de7f45d8ae581cb445ba78708db3ed25ff7eef94ee
diff --git a/dev-python/xmlschema/xmlschema-1.2.4.ebuild b/dev-python/xmlschema/xmlschema-1.2.4.ebuild
new file mode 100644
index 000000000000..6984a361dd20
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.2.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.0.2[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}