summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-03-16 09:17:36 +0100
committerTiziano Müller <dev-zero@gentoo.org>2016-03-16 09:17:36 +0100
commitbabc44d7ab86a7489126b9dc0dad6a711563deb9 (patch)
tree759edce8df3b9f47d86ca67386de40be98ca85f4 /dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild
parentsci-astronomy/stellarium: Stable for PPC64 (bug #574844). (diff)
downloadgentoo-babc44d7ab86a7489126b9dc0dad6a711563deb9.tar.gz
gentoo-babc44d7ab86a7489126b9dc0dad6a711563deb9.tar.bz2
gentoo-babc44d7ab86a7489126b9dc0dad6a711563deb9.zip
dev-python/xmltodict: rev-bump for py-3.5 compat and EAPI-6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild')
-rw-r--r--dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild b/dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..a96949862dd7
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.10.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}