summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-08 11:33:35 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-08 11:46:54 +0100
commit44f862c532e337cf087fac98221d018c61ebd151 (patch)
treef8fa9c891817480aa8ebb6784e3e6239e6f71862 /dev-python/xonsh/xonsh-0.2.6.ebuild
parentdev-python/networkx: Don't use banned EXAMPLES (diff)
downloadgentoo-44f862c532e337cf087fac98221d018c61ebd151.tar.gz
gentoo-44f862c532e337cf087fac98221d018c61ebd151.tar.bz2
gentoo-44f862c532e337cf087fac98221d018c61ebd151.zip
dev-python/xonsh: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/xonsh/xonsh-0.2.6.ebuild')
-rw-r--r--dev-python/xonsh/xonsh-0.2.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/xonsh/xonsh-0.2.6.ebuild b/dev-python/xonsh/xonsh-0.2.6.ebuild
new file mode 100644
index 000000000000..ae04e7ed0c4d
--- /dev/null
+++ b/dev-python/xonsh/xonsh-0.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="An exotic, usable shell"
+HOMEPAGE="
+ http://xonsh.readthedocs.org/
+ https://github.com/scopatz/xonsh
+ http://pypi.python.org/pypi/xonsh"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed \
+ -e "/install_kernel_spec/s:prefix=None:prefix=u\"${ED}/usr\":g" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter kernel support" dev-python/jupyter
+ optfeature "Alternative to readline backend" dev-python/prompt_toolkit
+}