summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-13 14:57:25 +0000
committerSam James <sam@gentoo.org>2021-01-13 14:59:02 +0000
commit9d7248b2d9c7f4a2605f4174306e4eb829e3dd14 (patch)
tree17161b90892f117bdab268e41b1a9e3200adaa90 /dev-python/yappi
parentdev-python/yappi: fix 1.3.0 tarball (diff)
downloadgentoo-9d7248b2d9c7f4a2605f4174306e4eb829e3dd14.tar.gz
gentoo-9d7248b2d9c7f4a2605f4174306e4eb829e3dd14.tar.bz2
gentoo-9d7248b2d9c7f4a2605f4174306e4eb829e3dd14.zip
dev-python/yappi: sync 1.3.2 with new 1.3.0 (test dep)
Adds the new dev-python/gevent test dependency. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/yappi')
-rw-r--r--dev-python/yappi/yappi-1.3.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/yappi/yappi-1.3.2.ebuild b/dev-python/yappi/yappi-1.3.2.ebuild
index ae71996be05c..b3c4ebc66022 100644
--- a/dev-python/yappi/yappi-1.3.2.ebuild
+++ b/dev-python/yappi/yappi-1.3.2.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python3_{7..9})
+
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,10 +18,10 @@ S="${WORKDIR}/${PN}-${COMMIT_HASH}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
-#RDEPEND="
-# $(python_gen_cond_dep 'dev-python/contextvars[${PYTHON_USEDEP}]' 'python3_6')
-#"
+BDEPEND="test? ( dev-python/gevent[${PYTHON_USEDEP}] )"
distutils_enable_tests unittest