summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-03-02 12:18:36 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-03-02 12:18:36 -0600
commit4790d192ce6120ac447d2a0ca2226fa519599e9d (patch)
treeb732cda805d9b3d526cd903d582ddabf02b74577 /dev-python/yaql/yaql-1.1.3.ebuild
parentdev-util/diffoscope: initial import (diff)
downloadgentoo-4790d192ce6120ac447d2a0ca2226fa519599e9d.tar.gz
gentoo-4790d192ce6120ac447d2a0ca2226fa519599e9d.tar.bz2
gentoo-4790d192ce6120ac447d2a0ca2226fa519599e9d.zip
dev-python/yaql: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/yaql/yaql-1.1.3.ebuild')
-rw-r--r--dev-python/yaql/yaql-1.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/yaql/yaql-1.1.3.ebuild b/dev-python/yaql/yaql-1.1.3.ebuild
new file mode 100644
index 000000000000..388ce33d51f0
--- /dev/null
+++ b/dev-python/yaql/yaql-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAQL: Yet Another Query Language"
+HOMEPAGE="https://github.com/openstack/yaql"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"