summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-12-30 23:40:11 -0800
committerZac Medico <zmedico@gentoo.org>2016-12-30 23:40:38 -0800
commitc7cdf5f9ed3cd07e11bb1454fbb308656d029d29 (patch)
tree80e0264f2edea2f8763fe31366fee6f1580716fc /dev-python/yarl/yarl-0.8.1.ebuild
parentsci-visualization/veusz: bump to 1.25.1 (diff)
downloadgentoo-c7cdf5f9ed3cd07e11bb1454fbb308656d029d29.tar.gz
gentoo-c7cdf5f9ed3cd07e11bb1454fbb308656d029d29.tar.bz2
gentoo-c7cdf5f9ed3cd07e11bb1454fbb308656d029d29.zip
dev-python/yarl: version bump to 0.8.1
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/yarl/yarl-0.8.1.ebuild')
-rw-r--r--dev-python/yarl/yarl-0.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-0.8.1.ebuild b/dev-python/yarl/yarl-0.8.1.ebuild
new file mode 100644
index 000000000000..260259aa619a
--- /dev/null
+++ b/dev-python/yarl/yarl-0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}