summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-19 13:08:45 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-20 02:20:02 -0700
commit111c4f7c02ca4a3725d8b102ea0e4508d39e713c (patch)
tree91a17b722a01c2488274255b4877b06843e023b9 /dev-python/yarl/yarl-0.9.8.ebuild
parentdev-python/URLObject: Tested on py3.5 & py3.6 (diff)
downloadgentoo-111c4f7c02ca4a3725d8b102ea0e4508d39e713c.tar.gz
gentoo-111c4f7c02ca4a3725d8b102ea0e4508d39e713c.tar.bz2
gentoo-111c4f7c02ca4a3725d8b102ea0e4508d39e713c.zip
dev-python/yarl: version bump to 0.9.8
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/yarl/yarl-0.9.8.ebuild')
-rw-r--r--dev-python/yarl/yarl-0.9.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-0.9.8.ebuild b/dev-python/yarl/yarl-0.9.8.ebuild
new file mode 100644
index 000000000000..c94d4ffb50ed
--- /dev/null
+++ b/dev-python/yarl/yarl-0.9.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}