summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-13 03:44:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-13 04:09:41 +0200
commit19dc258685b7c7480a4da6389163ab821cd5dc8d (patch)
tree9709d0338c5b84da8a8f618c542fd859c07ec523 /dev-python/yarl
parentdev-python/markdown: Bump to 3.3.1 (diff)
downloadgentoo-19dc258685b7c7480a4da6389163ab821cd5dc8d.tar.gz
gentoo-19dc258685b7c7480a4da6389163ab821cd5dc8d.tar.bz2
gentoo-19dc258685b7c7480a4da6389163ab821cd5dc8d.zip
dev-python/yarl: Bump to 1.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.6.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index bf25570e6c48..aac9f9931b90 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,2 +1,3 @@
DIST yarl-1.5.1.tar.gz 173005 BLAKE2B 08bfbe914a2f9a148e558d6db955b61c0d95d3f19d6da6290cf6bcd82f3b46ca58836aebd57e148d6f0fd2dfc4b1244f633e7f472b759c3a4fe0d620f80e3f3d SHA512 c82b0722f347279a03d3f6e82b7c0c357678e850b80ed87befab570846a71c55897cfa25d36757a93ac42c023334ecdf890beaeca7fde4536f68b6f70fdf2127
DIST yarl-1.6.0.tar.gz 175492 BLAKE2B e6e3ebb30a591fa1e94d07c353700b1ebf7c21a729d8c9a4cd582f591235d54dee40a109e28fb806893e281b9ab36ca2b1ca1cdf7f093587bde8a5a9c4e7bf89 SHA512 d08d2c4a906706bba3c1fad2b02e01299d076d9f6c1a1eb172d116d0ccbb1e6143b7dd959d242f2a1b5d450416bb15ab6e53ee9e05876b161d61ec23e054f29b
+DIST yarl-1.6.2.tar.gz 177534 BLAKE2B a7a587387c8030737874b445007aac4a7bc7f5552238fb892cbb99325e9a3862c599a11df5738d79e47dd1073e29731f80bd941f351e4a7b1867780fba9986ce SHA512 5e3ab46216d567583558a6945127d0d8d758475636deb0733bae25fc869d842f05e996f06aa4a7dc6fd067f7e38afdc6e328cc8019735819d2a1cebc50ca165d
diff --git a/dev-python/yarl/yarl-1.6.2.ebuild b/dev-python/yarl/yarl-1.6.2.ebuild
new file mode 100644
index 000000000000..28fd8a84c1dc
--- /dev/null
+++ b/dev-python/yarl/yarl-1.6.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.2-test-without-coverage.patch
+)