summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/yenc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/yenc')
-rw-r--r--dev-python/yenc/Manifest1
-rw-r--r--dev-python/yenc/files/yenc-remove-cflags.patch11
-rw-r--r--dev-python/yenc/metadata.xml7
-rw-r--r--dev-python/yenc/yenc-0.4.0-r1.ebuild30
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/yenc/Manifest b/dev-python/yenc/Manifest
new file mode 100644
index 000000000000..bbbaa7427443
--- /dev/null
+++ b/dev-python/yenc/Manifest
@@ -0,0 +1 @@
+DIST yenc-0.4.0.tar.gz 63156 SHA256 075f6c4e4f43b7c6dafac579eabb17287b62d80e9147cbea0b046bc3ee8edd2f SHA512 06adf10daa3eb56d1960e48c4a42c432821b8c25fcf6c703560efb9d902dc7619b79509a409f436790506f12f172fe0f0c6c1bf6bff7ab5ce3856b272c62c4d9 WHIRLPOOL e364ae573cfe57f51b1c7a47d1fd447bbd8144bce481d530fd1cda33ec41be9a3d8b05a6a92bdf6269997e5632bbdea426a1b4f324d74c2a9c78f35b5e337fb7
diff --git a/dev-python/yenc/files/yenc-remove-cflags.patch b/dev-python/yenc/files/yenc-remove-cflags.patch
new file mode 100644
index 000000000000..27721c727db3
--- /dev/null
+++ b/dev-python/yenc/files/yenc-remove-cflags.patch
@@ -0,0 +1,11 @@
+--- setup.py 2011-09-06 09:04:33.000000000 +0200
++++ setup.py.NEW 2012-07-07 15:33:13.295906002 +0200
+@@ -33,7 +33,7 @@
+ platforms = ["Unix"],
+ package_dir = { '': 'lib' },
+ py_modules = ["yenc"],
+- ext_modules = [Extension("_yenc",["src/_yenc.c"],extra_compile_args=["-O2","-g"])],
++ ext_modules = [Extension("_yenc",["src/_yenc.c"])],
+ classifiers = [
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.5",
diff --git a/dev-python/yenc/metadata.xml b/dev-python/yenc/metadata.xml
new file mode 100644
index 000000000000..c2318979e416
--- /dev/null
+++ b/dev-python/yenc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jsbronder@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/yenc/yenc-0.4.0-r1.ebuild b/dev-python/yenc/yenc-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f5a1d1578240
--- /dev/null
+++ b/dev-python/yenc/yenc-0.4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding"
+HOMEPAGE="http://www.golug.it/yenc.html"
+SRC_URI="http://www.golug.it/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Remove forced CFLAG on setup.py
+PATCHES=( "${FILESDIR}"/${PN}-remove-cflags.patch )
+DOCS=( README TODO CHANGES doc/${PN}-draft.1.3.txt )
+
+python_test() {
+ "${PYTHON}" test/test.py || die "Test failed."
+}
+
+src_test() {
+ # Tests use a constant temp file.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}