summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-08 18:20:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-08 18:25:18 -0600
commit85dde98934ae73bf47f6caa3d0adb9185532d556 (patch)
tree42aca36f38d9f976acc774ff2e08922f386aea52 /dev-python/zeroconf/zeroconf-0.19.1.ebuild
parentapp-admin/elektra: Remove live ebuild. (diff)
downloadgentoo-85dde98934ae73bf47f6caa3d0adb9185532d556.tar.gz
gentoo-85dde98934ae73bf47f6caa3d0adb9185532d556.tar.bz2
gentoo-85dde98934ae73bf47f6caa3d0adb9185532d556.zip
dev-python/zeroconf: 0.19.1 bup
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/zeroconf/zeroconf-0.19.1.ebuild')
-rw-r--r--dev-python/zeroconf/zeroconf-0.19.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/zeroconf/zeroconf-0.19.1.ebuild b/dev-python/zeroconf/zeroconf-0.19.1.ebuild
new file mode 100644
index 000000000000..5b6b4b8a2700
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.19.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="https://github.com/jstasiak/python-zeroconf https://pypi.python.org/pypi/zeroconf"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# Not included
+RESTRICT="test"
+
+python_prepare_all() {
+ # It's virtual/python-enum34
+ sed \
+ -e "s:'enum-compat',::g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}